summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 0b9d2b7530..e6c4a43f25 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -9071,3 +9071,25 @@ counters across multiple processes.")
(home-page
"http://github.com/matttproud/ruby_quantile_estimation")
(license license:asl2.0)))
+
+(define-public ruby-prometheus-client
+ (package
+ (name "ruby-prometheus-client")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "prometheus-client" version))
+ (sha256
+ (base32
+ "0ihbmnll7qkkhy5isd7vl3wrznyxm1havhzxhl8729im5qi6si51"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-quantile" ,ruby-quantile)))
+ (synopsis
+ "A suite of instrumentation metric primitivesthat can be exposed through a web services interface.")
+ (description
+ "This package provides a suite of instrumentation metric primitivesthat can be exposed through a web services interface.")
+ (home-page
+ "https://github.com/prometheus/client_ruby")
+ (license license:asl2.0)))