summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/clojure.scm293
-rw-r--r--gnu/packages/file-systems.scm49
-rw-r--r--gnu/packages/freedesktop.scm6
-rw-r--r--gnu/packages/gnome.scm2
-rw-r--r--gnu/packages/linux.scm16
-rw-r--r--gnu/packages/lisp.scm354
-rw-r--r--gnu/packages/ocaml.scm1
-rw-r--r--gnu/packages/scheme.scm51
-rw-r--r--guix/build-system/clojure.scm2
10 files changed, 431 insertions, 344 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3391c4f522..8b673fdd8a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -101,6 +101,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/chez.scm \
%D%/packages/ci.scm \
%D%/packages/cinnamon.scm \
+ %D%/packages/clojure.scm \
%D%/packages/cluster.scm \
%D%/packages/cmake.scm \
%D%/packages/cobol.scm \
diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
new file mode 100644
index 0000000000..1dba4cef87
--- /dev/null
+++ b/gnu/packages/clojure.scm
@@ -0,0 +1,293 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages clojure)
+ #:use-module (gnu packages)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system ant)
+ #:use-module (guix build-system clojure)
+ #:use-module (ice-9 match))
+
+(define-public clojure
+ (let* ((lib (lambda (prefix version hash)
+ (origin (method url-fetch)
+ (uri (string-append "https://github.com/clojure/"
+ prefix version ".tar.gz"))
+ (sha256 (base32 hash)))))
+ ;; The libraries below are needed to run the tests.
+ (libraries
+ `(("core-specs-alpha-src"
+ ,(lib "core.specs.alpha/archive/core.specs.alpha-"
+ "0.1.24"
+ "0v2a0svf1ar2y42ajxwsjr7zmm5j7pp2zwrd2jh3k7xzd1p9x1fv"))
+ ("data-generators-src"
+ ,(lib "data.generators/archive/data.generators-"
+ "0.1.2"
+ "0kki093jp4ckwxzfnw8ylflrfqs8b1i1wi9iapmwcsy328dmgzp1"))
+ ("spec-alpha-src"
+ ,(lib "spec.alpha/archive/spec.alpha-"
+ "0.1.143"
+ "00alf0347licdn773w2jarpllyrbl52qz4d8mw61anjksacxylzz"))
+ ("test-check-src"
+ ,(lib "test.check/archive/test.check-"
+ "0.9.0"
+ "0p0mnyhr442bzkz0s4k5ra3i6l5lc7kp6ajaqkkyh4c2k5yck1md"))
+ ("test-generative-src"
+ ,(lib "test.generative/archive/test.generative-"
+ "0.5.2"
+ "1pjafy1i7yblc7ixmcpfq1lfbyf3jaljvkgrajn70sws9xs7a9f8"))
+ ("tools-namespace-src"
+ ,(lib "tools.namespace/archive/tools.namespace-"
+ "0.2.11"
+ "10baak8v0hnwz2hr33bavshm7y49mmn9zsyyms1dwjz45p5ymhy0"))))
+ (library-names (match libraries
+ (((library-name _) ...)
+ library-name))))
+
+ (package
+ (name "clojure")
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/clojure/clojure/archive/clojure-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0xjbzcw45z32vsn9pifp7ndysjzqswp5ig0jkjpivigh2ckkdzha"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:imported-modules ((guix build clojure-utils)
+ (guix build guile-build-system)
+ ,@%ant-build-system-modules)
+ #:modules ((guix build ant-build-system)
+ (guix build clojure-utils)
+ (guix build java-utils)
+ (guix build utils)
+ (srfi srfi-26))
+ #:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'unpack-library-sources
+ (lambda* (#:key inputs #:allow-other-keys)
+ (define (extract-library name)
+ (mkdir-p name)
+ (with-directory-excursion name
+ (invoke "tar"
+ "--extract"
+ "--verbose"
+ "--file" (assoc-ref inputs name)
+ "--strip-components=1"))
+ (copy-recursively (string-append name "/src/main/clojure/")
+ "src/clj/"))
+ (for-each extract-library ',library-names)
+ #t))
+ (add-after 'unpack-library-sources 'fix-manifest-classpath
+ (lambda _
+ (substitute* "build.xml"
+ (("<attribute name=\"Class-Path\" value=\".\"/>") ""))
+ #t))
+ (add-after 'build 'build-javadoc ant-build-javadoc)
+ (replace 'install (install-jars "./"))
+ (add-after 'install-license-files 'install-doc
+ (cut install-doc #:doc-dirs '("doc/clojure/") <...>))
+ (add-after 'install-doc 'install-javadoc
+ (install-javadoc "target/javadoc/")))))
+ (native-inputs libraries)
+ (home-page "https://clojure.org/")
+ (synopsis "Lisp dialect running on the JVM")
+ (description "Clojure is a dynamic, general-purpose programming language,
+combining the approachability and interactive development of a scripting
+language with an efficient and robust infrastructure for multithreaded
+programming. Clojure is a compiled language, yet remains completely dynamic
+– every feature supported by Clojure is supported at runtime. Clojure
+provides easy access to the Java frameworks, with optional type hints and type
+inference, to ensure that calls to Java can avoid reflection.
+
+Clojure is a dialect of Lisp, and shares with Lisp the code-as-data philosophy
+and a powerful macro system. Clojure is predominantly a functional programming
+language, and features a rich set of immutable, persistent data structures.
+When mutable state is needed, Clojure offers a software transactional memory
+system and reactive Agent system that ensure clean, correct, multithreaded
+designs.")
+ ;; Clojure is licensed under EPL1.0
+ ;; ASM bytecode manipulation library is licensed under BSD-3
+ ;; Guava Murmur3 hash implementation is licensed under APL2.0
+ ;; src/clj/repl.clj is licensed under CPL1.0
+
+ ;; See readme.html or readme.txt for details.
+ (license (list license:epl1.0
+ license:bsd-3
+ license:asl2.0
+ license:cpl1.0)))))
+
+(define-public clojure-algo-generic
+ (package
+ (name "clojure-algo-generic")
+ (version "0.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/clojure/algo.generic/archive"
+ "/algo.generic-" version ".tar.gz"))
+ (sha256
+ (base32 "12w9681i545gp1af4576z1qbixwps1j13c16fmcc7zsb0bd1zr7w"))))
+ (build-system clojure-build-system)
+ (arguments
+ '(#:source-dirs '("src/main/clojure/")
+ #:test-dirs '("src/test/clojure/")
+ #:doc-dirs '()))
+ (synopsis "Generic versions of common functions")
+ (description
+ "Generic versions of commonly used functions, implemented as multimethods
+that can be implemented for any data type.")
+ (home-page "https://github.com/clojure/algo.generic")
+ (license license:epl1.0)))
+
+(define-public clojure-algo-monads
+ (package
+ (name "clojure-algo-monads")
+ (version "0.1.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/clojure/algo.monads/archive"
+ "/algo.monads-" version ".tar.gz"))
+ (sha256
+ (base32 "14gbvfgmrda990h45yn7zag83vp1kdkz4f4yzmyvkr0sjihlgdmq"))))
+ (build-system clojure-build-system)
+ (arguments
+ '(#:source-dirs '("src/main/clojure/")
+ #:test-dirs '("src/test/clojure/")
+ #:doc-dirs '()))
+ (native-inputs
+ `(("clojure-tools-macro" ,clojure-tools-macro)))
+ (synopsis
+ "Monad Macros and Definitions")
+ (description
+ "This library contains the most commonly used monads as well as macros for
+defining and using monads and useful monadic functions.")
+ (home-page "https://github.com/clojure/algo.monads")
+ (license license:epl1.0)))
+
+(define-public clojure-core-match
+ (let ((commit "1837ffbd4a150e8f3953b2d9ed5cf4a4ad3720a7")
+ (revision "1")) ; this is the 1st commit buildable with clojure 1.9
+ (package
+ (name "clojure-core-match")
+ (version (git-version "0.3.0-alpha5" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/clojure/core.match.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "04bdlp5dgkrqzrz0lw3mfwmygj2218qnm1cz3dkb9wy4m0238s4d"))))
+ (build-system clojure-build-system)
+ (arguments
+ '(#:source-dirs '("src/main/clojure")
+ #:test-dirs '("src/test/clojure")
+ #:doc-dirs '()))
+ (synopsis "Optimized pattern matching for Clojure")
+ (description
+ "An optimized pattern matching library for Clojure.
+It supports Clojure 1.5.1 and later as well as ClojureScript.")
+ (home-page "https://github.com/clojure/core.match")
+ (license license:epl1.0))))
+
+(define-public clojure-instaparse
+ (let ((commit "dcfffad5b065e750f0f5835f017cdd8188b8ca2e")
+ (version "1.4.9")) ; upstream forget to tag this release
+ (package
+ (name "clojure-instaparse")
+ (version version)
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Engelberg/instaparse.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "002mrgin4z3dqy88r1lak7smd0m7x8d22vmliw0m6w6mh5pa17lk"))))
+ (build-system clojure-build-system)
+ (arguments
+ '(#:doc-dirs '("docs/")))
+ (synopsis "No grammar left behind")
+ (description
+ "Instaparse aims to be the simplest way to build parsers in Clojure.
+
+@itemize
+@item Turns @emph{standard EBNF or ABNF notation} for context-free grammars
+into an executable parser that takes a string as an input and produces a parse
+tree for that string.
+
+@item @dfn{No Grammar Left Behind}: Works for @emph{any} context-free grammar,
+including @emph{left-recursive}, @emph{right-recursive}, and @emph{ambiguous}
+grammars.
+
+@item Extends the power of context-free grammars with PEG-like syntax for
+lookahead and negative lookahead.
+
+@item Supports both of Clojure's most popular tree formats (hiccup and enlive)
+as output targets
+
+@item Detailed reporting of parse errors.
+
+@item Optionally produces lazy sequence of all parses (especially useful for
+diagnosing and debugging ambiguous grammars).
+
+@item ``Total parsing'' mode where leftover string is embedded in the parse
+tree.
+
+@item Optional combinator library for building grammars programmatically.
+
+@item Performant.
+@end itemize")
+ (home-page "https://github.com/Engelberg/instaparse")
+ (license license:epl1.0))))
+
+(define-public clojure-tools-macro
+ (package
+ (name "clojure-tools-macro")
+ (version "0.1.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/clojure/tools.macro/archive"
+ "/tools.macro-" version ".tar.gz"))
+ (sha256
+ (base32 "0fs64a0g63xx6g7sj6vrsqknhl90s0isf6k053nw8vv5prfzc7v6"))))
+ (build-system clojure-build-system)
+ (arguments
+ '(#:source-dirs '("src/main/clojure/")
+ #:test-dirs '("src/test/clojure/")
+ #:doc-dirs '()))
+ (synopsis "Utilities for macro writers")
+ (description "Tools for writing macros.")
+ (home-page "https://github.com/clojure/tools.macro")
+ (license license:epl1.0)))
diff --git a/gnu/packages/file-systems.scm b/gnu/packages/file-systems.scm
index f250719bbd..93d1561948 100644
--- a/gnu/packages/file-systems.scm
+++ b/gnu/packages/file-systems.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,6 +24,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -245,3 +247,50 @@ All of this is accomplished without a centralized metadata server.")
(description
"This is a file system client based on the FTP File Transfer Protocol.")
(license license:gpl2+)))
+
+(define-public apfs-fuse
+ (let ((commit "c7036a3030d128bcecefc1eabc47c039ccfdcec9")
+ (revision "0"))
+ (package
+ (name "apfs-fuse")
+ (version (git-version "0.0.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sgan81/apfs-fuse")
+ (recursive? #t) ; for lzfse
+ (commit commit)))
+ (sha256
+ (base32
+ "1akd4cx1f9cyq6sfk9ybv4chhjwjlnqi8ic4z5ajnd5x0g76nz3r"))
+ (file-name (git-file-name name version))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ; No test suite
+ #:phases
+ (modify-phases %standard-phases
+ ;; No 'install' target in CMakeLists.txt
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (lib (string-append out "/lib"))
+ (doc (string-append out "/share/doc/"
+ (string-append ,name "-" ,version))))
+ (install-file "apfs-dump" bin)
+ (install-file "apfs-dump-quick" bin)
+ (install-file "apfs-fuse" bin)
+ (install-file "libapfs.a" lib)
+ (install-file "../source/LICENSE" doc)
+ #t))))))
+ (inputs
+ `(("bzip2" ,bzip2)
+ ("fuse" ,fuse)
+ ("zlib" ,zlib)))
+ (synopsis "Read-only FUSE driver for the APFS filesystem")
+ (description "APFS-FUSE is a read-only FUSE driver for the @dfn{Apple File
+System} (APFS). It is currently in an experimental state — it may not be able
+to read all files, and it does not support all the compression methods in
+APFS.")
+ (home-page "https://github.com/sgan81/apfs-fuse")
+ (license license:gpl2+))))
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 8853ce1ceb..293916c4d2 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -67,16 +67,14 @@
#:use-module (gnu packages m4)
#:use-module (gnu packages perl)
#:use-module (gnu packages perl-check)
- #:use-module (gnu packages polkit)
#:use-module (gnu packages pkg-config)
- #:use-module (gnu packages perl)
- #:use-module (gnu packages perl-check)
+ #:use-module (gnu packages polkit)
#:use-module (gnu packages python)
#:use-module (gnu packages valgrind)
#:use-module (gnu packages w3m)
#:use-module (gnu packages web)
- #:use-module (gnu packages xml)
#:use-module (gnu packages xdisorg)
+ #:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
#:use-module (srfi srfi-1))
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e94779c482..026b5fd59c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3752,7 +3752,7 @@ which can read a large number of file formats.")
"b182c6b9e1d09e601bac0b703cc5f8b159ebbc3a.patch"))
(sha256
(base32
- "17j45vyyr071ka3nckj2gycgyyv1j08fyrxw89jfdq2442nzrsiy")))))
+ "06n87xgf927djmv1vshal84nqx7g8nwgljza3g2vydhy7g2n1csq")))))
(sha256
(base32
"0hzcns8gf5yb0rm4ss8jd8qzarcaplp5cylk6plwilsqfvxj4xn2"))))
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 661b7ed2ca..ad05264f9a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -400,8 +400,8 @@ It has been modified to remove all non-free binary blobs.")
;; supports qemu "virt" machine and possibly a large number of ARM boards.
;; See : https://wiki.debian.org/DebianKernel/ARMMP.
-(define %linux-libre-version "4.19.2")
-(define %linux-libre-hash "1yh4ll9qh4wmf9r62ksyic57g1iy1b84qbv855l545ilk12znbmj")
+(define %linux-libre-version "4.19.4")
+(define %linux-libre-hash "0m5k14a89bf5avr3kdh3909qjfnd051fbsb0v7a52d54dkg2nbp6")
(define %linux-libre-4.19-patches
(list %boot-logo-patch
@@ -423,8 +423,8 @@ It has been modified to remove all non-free binary blobs.")
#:patches %linux-libre-4.19-patches
#:configuration-file kernel-config))
-(define %linux-libre-4.14-version "4.14.81")
-(define %linux-libre-4.14-hash "0vxs8k7ka8aqnn1fcr88bhr07wa5jg83pq1rcjby9k422mbv254q")
+(define %linux-libre-4.14-version "4.14.83")
+(define %linux-libre-4.14-hash "0x6r09bqdrcqigyjx922vji3pdv36l24pl0j33xs8b7xawkvii9g")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
@@ -433,14 +433,14 @@ It has been modified to remove all non-free binary blobs.")
#:configuration-file kernel-config))
(define-public linux-libre-4.9
- (make-linux-libre "4.9.137"
- "1d8313r2k0qr4x7nqlnbwn5lzfc7dz6w8sfg47jml1q38c2fyjf2"
+ (make-linux-libre "4.9.140"
+ "12amh7m0khjx5q3bcv8sq59xkanaxa5xnw4m1iql7503nk4pgg9a"
%intel-compatible-systems
#:configuration-file kernel-config))
(define-public linux-libre-4.4
- (make-linux-libre "4.4.163"
- "05j0dm0cxilanp5z40n8kgjz9vn1p4rg63kksicd2v48w8ka82z6"
+ (make-linux-libre "4.4.164"
+ "04w4x97bkd2javjws9pzv1shfcrhyn4nf9w8b6qk6zdaj45fzasb"
%intel-compatible-systems
#:configuration-file kernel-config))
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index caa90d5a0a..a3649e5bd6 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36,7 +37,6 @@
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system ant)
- #:use-module (guix build-system clojure)
#:use-module (guix build-system asdf)
#:use-module (guix build-system trivial)
#:use-module (gnu packages admin)
@@ -69,7 +69,6 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages webkit)
#:use-module (ice-9 match)
- #:use-module (srfi srfi-1)
#:use-module (srfi srfi-19))
(define (asdf-substitutions lisp)
@@ -170,8 +169,7 @@
(native-inputs
`(("gcc" ,gcc-4.9)
("m4" ,m4)
- ("texinfo" ,texinfo)
- ("texlive" ,texlive)))
+ ("texinfo" ,texinfo)))
(home-page "https://www.gnu.org/software/gcl/")
(synopsis "A Common Lisp implementation")
(description "GCL is an implementation of the Common Lisp language. It
@@ -318,14 +316,14 @@ an interpreter, a compiler, a debugger, and much more.")
(define-public sbcl
(package
(name "sbcl")
- (version "1.4.4")
+ (version "1.4.13")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/sbcl/sbcl/" version "/sbcl-"
version "-source.tar.bz2"))
(sha256
- (base32 "1k6v5b8qv7vyxvh8asx6phf2hbapx5pp5p5j47hgnq123fwnh4fa"))
+ (base32 "120rnnz8367lk7ljqlf8xidm4b0d738xqsib4kq0q5ms5r7fzgvm"))
(modules '((guix build utils)))
(snippet
;; Add sbcl-bundle-systems to 'default-system-source-registry'.
@@ -337,11 +335,20 @@ an interpreter, a compiler, a debugger, and much more.")
(outputs '("out" "doc"))
;; Bootstrap with CLISP.
(native-inputs
- `(("clisp" ,clisp)
+ ;; From INSTALL:
+ ;; Supported build hosts are:
+ ;; SBCL
+ ;; CMUCL
+ ;; CCL (formerly known as OpenMCL)
+ ;; ABCL (recent versions only)
+ ;; CLISP (only some versions: 2.44.1 is OK, 2.47 is not)
+ ;; XCL
+ ;; CCL seems ideal then.
+ `(("ccl" ,ccl)
("which" ,which)
("inetutils" ,inetutils) ;for hostname(1)
("ed" ,ed)
- ("texlive" ,texlive)
+ ("texlive" ,(texlive-union (list texlive-tex-texinfo)))
("texinfo" ,texinfo)))
(arguments
'(#:modules ((guix build gnu-build-system)
@@ -396,20 +403,24 @@ an interpreter, a compiler, a debugger, and much more.")
(string-append "#+nil ;disabled by Guix\n" all))
(("\\(deftest grent\\.[12]" all)
(string-append "#+nil ;disabled by Guix\n" all))))))
+ ;; FIXME: the texlive-union insists on regenerating fonts. It stores
+ ;; them in HOME, so it needs to be writeable.
+ (add-before 'build 'set-HOME
+ (lambda _ (setenv "HOME" "/tmp") #t))
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(setenv "CC" "gcc")
- (zero? (system* "sh" "make.sh" "clisp"
- (string-append "--prefix="
- (assoc-ref outputs "out"))))))
+ (invoke "sh" "make.sh" "ccl"
+ (string-append "--prefix="
+ (assoc-ref outputs "out")))))
(replace 'install
(lambda _
- (zero? (system* "sh" "install.sh"))))
+ (invoke "sh" "install.sh")))
(add-after 'build 'build-doc
(lambda _
(with-directory-excursion "doc/manual"
- (and (zero? (system* "make" "info"))
- (zero? (system* "make" "dist"))))))
+ (and (invoke "make" "info")
+ (invoke "make" "dist")))))
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -566,169 +577,6 @@ interface.")
(license (list license:lgpl2.1
license:clarified-artistic)))) ;TRIVIAL-LDAP package
-(define-public clojure
- (let* ((lib (lambda (prefix version hash)
- (origin (method url-fetch)
- (uri (string-append "https://github.com/clojure/"
- prefix version ".tar.gz"))
- (sha256 (base32 hash)))))
- ;; The libraries below are needed to run the tests.
- (libraries
- `(("core-specs-alpha-src"
- ,(lib "core.specs.alpha/archive/core.specs.alpha-"
- "0.1.24"
- "0v2a0svf1ar2y42ajxwsjr7zmm5j7pp2zwrd2jh3k7xzd1p9x1fv"))
- ("data-generators-src"
- ,(lib "data.generators/archive/data.generators-"
- "0.1.2"
- "0kki093jp4ckwxzfnw8ylflrfqs8b1i1wi9iapmwcsy328dmgzp1"))
- ("spec-alpha-src"
- ,(lib "spec.alpha/archive/spec.alpha-"
- "0.1.143"
- "00alf0347licdn773w2jarpllyrbl52qz4d8mw61anjksacxylzz"))
- ("test-check-src"
- ,(lib "test.check/archive/test.check-"
- "0.9.0"
- "0p0mnyhr442bzkz0s4k5ra3i6l5lc7kp6ajaqkkyh4c2k5yck1md"))
- ("test-generative-src"
- ,(lib "test.generative/archive/test.generative-"
- "0.5.2"
- "1pjafy1i7yblc7ixmcpfq1lfbyf3jaljvkgrajn70sws9xs7a9f8"))
- ("tools-namespace-src"
- ,(lib "tools.namespace/archive/tools.namespace-"
- "0.2.11"
- "10baak8v0hnwz2hr33bavshm7y49mmn9zsyyms1dwjz45p5ymhy0"))))
- (library-names (match libraries
- (((library-name _) ...)
- library-name))))
-
- (package
- (name "clojure")
- (version "1.9.0")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/clojure/clojure/archive/clojure-"
- version ".tar.gz"))
- (sha256
- (base32 "0xjbzcw45z32vsn9pifp7ndysjzqswp5ig0jkjpivigh2ckkdzha"))))
- (build-system ant-build-system)
- (arguments
- `(#:imported-modules ((guix build clojure-utils)
- (guix build guile-build-system)
- ,@%ant-build-system-modules)
- #:modules ((guix build ant-build-system)
- (guix build clojure-utils)
- (guix build java-utils)
- (guix build utils)
- (srfi srfi-26))
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'unpack-library-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (define (extract-library name)
- (mkdir-p name)
- (with-directory-excursion name
- (invoke "tar"
- "--extract"
- "--verbose"
- "--file" (assoc-ref inputs name)
- "--strip-components=1"))
- (copy-recursively (string-append name "/src/main/clojure/")
- "src/clj/"))
- (for-each extract-library ',library-names)
- #t))
- (add-after 'unpack-library-sources 'fix-manifest-classpath
- (lambda _
- (substitute* "build.xml"
- (("<attribute name=\"Class-Path\" value=\".\"/>") ""))
- #t))
- (add-after 'build 'build-javadoc ant-build-javadoc)
- (replace 'install (install-jars "./"))
- (add-after 'install-license-files 'install-doc
- (cut install-doc #:doc-dirs '("doc/clojure/") <...>))
- (add-after 'install-doc 'install-javadoc
- (install-javadoc "target/javadoc/")))))
- (native-inputs libraries)
- (home-page "https://clojure.org/")
- (synopsis "Lisp dialect running on the JVM")
- (description "Clojure is a dynamic, general-purpose programming language,
-combining the approachability and interactive development of a scripting
-language with an efficient and robust infrastructure for multithreaded
-programming. Clojure is a compiled language, yet remains completely dynamic
-– every feature supported by Clojure is supported at runtime. Clojure
-provides easy access to the Java frameworks, with optional type hints and type
-inference, to ensure that calls to Java can avoid reflection.
-
-Clojure is a dialect of Lisp, and shares with Lisp the code-as-data philosophy
-and a powerful macro system. Clojure is predominantly a functional programming
-language, and features a rich set of immutable, persistent data structures.
-When mutable state is needed, Clojure offers a software transactional memory
-system and reactive Agent system that ensure clean, correct, multithreaded
-designs.")
- ;; Clojure is licensed under EPL1.0
- ;; ASM bytecode manipulation library is licensed under BSD-3
- ;; Guava Murmur3 hash implementation is licensed under APL2.0
- ;; src/clj/repl.clj is licensed under CPL1.0
-
- ;; See readme.html or readme.txt for details.
- (license (list license:epl1.0
- license:bsd-3
- license:asl2.0
- license:cpl1.0)))))
-
-(define-public femtolisp
- (let ((commit "68c5b1225572ecf2c52baf62f928063e5a30511b")
- (revision "1"))
- (package
- (name "femtolisp")
- (version (string-append "0.0.0-" revision "." (string-take commit 7)))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JeffBezanson/femtolisp.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "04rnwllxnl86zw8c6pwxznn49bvkvh0f1lfliy085vjzvlq3rgja"))))
- ;; See "utils.h" for supported systems. Upstream bug:
- ;; https://github.com/JeffBezanson/femtolisp/issues/25
- (supported-systems
- (fold delete %supported-systems
- '("armhf-linux" "mips64el-linux" "aarch64-linux")))
- (build-system gnu-build-system)
- (arguments
- `(#:make-flags '("CC=gcc" "release")
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (delete 'configure) ; No configure script
- (replace 'install ; Makefile has no 'install phase
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (install-file "flisp" bin)
- #t)))
- ;; The flisp binary is now available, run bootstrap to
- ;; generate flisp.boot and afterwards runs make test.
- (add-after 'install 'bootstrap-gen-and-test
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (and
- (zero? (system* "./bootstrap.sh"))
- (install-file "flisp.boot" bin))))))))
- (synopsis "Scheme-like lisp implementation")
- (description
- "@code{femtolisp} is a scheme-like lisp implementation with a
-simple, elegant Scheme dialect. It is a lisp-1 with lexical scope.
-The core is 12 builtin special forms and 33 builtin functions.")
- (home-page "https://github.com/JeffBezanson/femtolisp")
- (license license:bsd-3))))
-
(define-public lush2
(package
(name "lush2")
@@ -1608,158 +1456,6 @@ compressor. It works on data produced by @code{parse-js} to generate a
("sbcl-cl-uglify-js" ,sbcl-cl-uglify-js)))
(synopsis "JavaScript compressor")))
-(define-public clojure-algo-generic
- (package
- (name "clojure-algo-generic")
- (version "0.1.3")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/clojure/algo.generic/archive"
- "/algo.generic-" version ".tar.gz"))
- (sha256
- (base32 "12w9681i545gp1af4576z1qbixwps1j13c16fmcc7zsb0bd1zr7w"))))
- (build-system clojure-build-system)
- (arguments
- '(#:source-dirs '("src/main/clojure/")
- #:test-dirs '("src/test/clojure/")
- #:doc-dirs '()))
- (synopsis "Generic versions of common functions")
- (description
- "Generic versions of commonly used functions, implemented as multimethods
-that can be implemented for any data type.")
- (home-page "https://github.com/clojure/algo.generic")
- (license license:epl1.0)))
-
-(define-public clojure-algo-monads
- (package
- (name "clojure-algo-monads")
- (version "0.1.6")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/clojure/algo.monads/archive"
- "/algo.monads-" version ".tar.gz"))
- (sha256
- (base32 "14gbvfgmrda990h45yn7zag83vp1kdkz4f4yzmyvkr0sjihlgdmq"))))
- (build-system clojure-build-system)
- (arguments
- '(#:source-dirs '("src/main/clojure/")
- #:test-dirs '("src/test/clojure/")
- #:doc-dirs '()))
- (native-inputs
- `(("clojure-tools-macro" ,clojure-tools-macro)))
- (synopsis
- "Monad Macros and Definitions")
- (description
- "This library contains the most commonly used monads as well as macros for
-defining and using monads and useful monadic functions.")
- (home-page "https://github.com/clojure/algo.monads")
- (license license:epl1.0)))
-
-(define-public clojure-core-match
- (let ((commit "1837ffbd4a150e8f3953b2d9ed5cf4a4ad3720a7")
- (revision "1")) ; this is the 1st commit buildable with clojure 1.9
- (package
- (name "clojure-core-match")
- (version (git-version "0.3.0-alpha5" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/clojure/core.match.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "04bdlp5dgkrqzrz0lw3mfwmygj2218qnm1cz3dkb9wy4m0238s4d"))))
- (build-system clojure-build-system)
- (arguments
- '(#:source-dirs '("src/main/clojure")
- #:test-dirs '("src/test/clojure")
- #:doc-dirs '()))
- (synopsis "Optimized pattern matching for Clojure")
- (description
- "An optimized pattern matching library for Clojure.
-It supports Clojure 1.5.1 and later as well as ClojureScript.")
- (home-page "https://github.com/clojure/core.match")
- (license license:epl1.0))))
-
-(define-public clojure-instaparse
- (let ((commit "dcfffad5b065e750f0f5835f017cdd8188b8ca2e")
- (version "1.4.9")) ; upstream forget to tag this release
- (package
- (name "clojure-instaparse")
- (version version)
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Engelberg/instaparse.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "002mrgin4z3dqy88r1lak7smd0m7x8d22vmliw0m6w6mh5pa17lk"))))
- (build-system clojure-build-system)
- (arguments
- '(#:doc-dirs '("docs/")))
- (synopsis "No grammar left behind")
- (description
- "Instaparse aims to be the simplest way to build parsers in Clojure.
-
-@itemize
-@item Turns @emph{standard EBNF or ABNF notation} for context-free grammars
-into an executable parser that takes a string as an input and produces a parse
-tree for that string.
-
-@item @dfn{No Grammar Left Behind}: Works for @emph{any} context-free grammar,
-including @emph{left-recursive}, @emph{right-recursive}, and @emph{ambiguous}
-grammars.
-
-@item Extends the power of context-free grammars with PEG-like syntax for
-lookahead and negative lookahead.
-
-@item Supports both of Clojure's most popular tree formats (hiccup and enlive)
-as output targets
-
-@item Detailed reporting of parse errors.
-
-@item Optionally produces lazy sequence of all parses (especially useful for
-diagnosing and debugging ambiguous grammars).
-
-@item ``Total parsing'' mode where leftover string is embedded in the parse
-tree.
-
-@item Optional combinator library for building grammars programmatically.
-
-@item Performant.
-@end itemize")
- (home-page "https://github.com/Engelberg/instaparse")
- (license license:epl1.0))))
-
-(define-public clojure-tools-macro
- (package
- (name "clojure-tools-macro")
- (version "0.1.5")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/clojure/tools.macro/archive"
- "/tools.macro-" version ".tar.gz"))
- (sha256
- (base32 "0fs64a0g63xx6g7sj6vrsqknhl90s0isf6k053nw8vv5prfzc7v6"))))
- (build-system clojure-build-system)
- (arguments
- '(#:source-dirs '("src/main/clojure/")
- #:test-dirs '("src/test/clojure/")
- #:doc-dirs '()))
- (synopsis "Utilities for macro writers")
- (description "Tools for writing macros.")
- (home-page "https://github.com/clojure/tools.macro")
- (license license:epl1.0)))
-
(define-public confusion-mdl
(let* ((commit "12a055581fc262225272df43287dae48281900f5"))
(package
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index e1323582a2..8c6e1da7d1 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4297,7 +4297,6 @@ cpp-like directives.")
("ulex" ,ocaml-ulex)
("easy-format" ,ocaml-easy-format)
("base64" ,ocaml-base64)))
- (home-page "http://www.cduce.org/download.html#side")
(home-page "http://piqi.org")
(synopsis "Data serialization and conversion library")
(description "Piqilib is the common library used by the piqi command-line
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 9654fe36f5..c03c53b91f 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -66,6 +66,7 @@
#:use-module (gnu packages tls)
#:use-module (gnu packages gl)
#:use-module (gnu packages libedit)
+ #:use-module (srfi srfi-1)
#:use-module (ice-9 match))
(define (mit-scheme-source-directory system version)
@@ -1095,3 +1096,53 @@ in-lining, unboxing, and flow-directed program-specific and
program-point-specific low-level representation selection and code
generation.")
(license gpl2+))))
+
+(define-public femtolisp
+ (let ((commit "68c5b1225572ecf2c52baf62f928063e5a30511b")
+ (revision "1"))
+ (package
+ (name "femtolisp")
+ (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JeffBezanson/femtolisp.git")
+ (commit commit)))
+ (file-name (string-append name "-" version "-checkout"))
+ (sha256
+ (base32
+ "04rnwllxnl86zw8c6pwxznn49bvkvh0f1lfliy085vjzvlq3rgja"))))
+ ;; See "utils.h" for supported systems. Upstream bug:
+ ;; https://github.com/JeffBezanson/femtolisp/issues/25
+ (supported-systems
+ (fold delete %supported-systems
+ '("armhf-linux" "mips64el-linux" "aarch64-linux")))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:make-flags '("CC=gcc" "release")
+ #:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure) ; No configure script
+ (replace 'install ; Makefile has no 'install phase
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (install-file "flisp" bin)
+ #t)))
+ ;; The flisp binary is now available, run bootstrap to
+ ;; generate flisp.boot and afterwards runs make test.
+ (add-after 'install 'bootstrap-gen-and-test
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (and
+ (zero? (system* "./bootstrap.sh"))
+ (install-file "flisp.boot" bin))))))))
+ (synopsis "Scheme-like lisp implementation")
+ (description
+ "@code{femtolisp} is a scheme-like lisp implementation with a
+simple, elegant Scheme dialect. It is a lisp-1 with lexical scope.
+The core is 12 builtin special forms and 33 builtin functions.")
+ (home-page "https://github.com/JeffBezanson/femtolisp")
+ (license bsd-3))))
diff --git a/guix/build-system/clojure.scm b/guix/build-system/clojure.scm
index 5a91bcba00..d70535c9e3 100644
--- a/guix/build-system/clojure.scm
+++ b/guix/build-system/clojure.scm
@@ -51,7 +51,7 @@
(define-with-docs %default-clojure
"The default Clojure package."
- (delay (@* (gnu packages lisp) clojure)))
+ (delay (@* (gnu packages clojure) clojure)))
(define-with-docs %default-jdk
"The default JDK package."