summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index eaa674e070..675778b315 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1619,6 +1619,32 @@ standard output stream.")
"https://github.com/liufengyun/hashdiff")
(license license:expat)))
+(define-public ruby-httparty
+ (package
+ (name "ruby-httparty")
+ (version "0.16.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "httparty" version))
+ (sha256
+ (base32
+ "1zsc40nrg5fbaabbjcklnrgwgg6qdqycvg5sq8iahp1v8jxfarzw"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "spec"))
+ (propagated-inputs
+ `(("ruby-multi-xml" ,ruby-multi-xml)))
+ (native-inputs
+ `(("ruby-cucumber" ,ruby-cucumber)))
+ (synopsis
+ "Makes http fun! Also, makes consuming restful web services dead easy.")
+ (description
+ "Makes http fun! Also, makes consuming restful web services dead easy.")
+ (home-page
+ "http://jnunemaker.github.com/httparty")
+ (license license:expat)))
+
(define-public ruby-shindo
(package
(name "ruby-shindo")