summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--release.nix7
1 files changed, 4 insertions, 3 deletions
diff --git a/release.nix b/release.nix
index 8d87d03bda..28fde3b956 100644
--- a/release.nix
+++ b/release.nix
@@ -46,9 +46,10 @@ let
configureFlags =
[ "--with-nixpkgs=${nixpkgs}" "--with-nix-prefix=${pkgs.nix}" ];
- # XXX: The test suite cannot be run currently in the chroot, because
- # it expects to have a running nix-worker to talk to.
- doCheck = false;
+ # XXX: Since we need to talk to a running daemon, for the benefit of
+ # `nixpkgs-derivation*' & co., we need to escape the chroot.
+ preConfigure = "export NIX_REMOTE=daemon";
+ __noChroot = true;
};
};
in