summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-10-26 11:20:08 +0200
committerLudovic Courtès <ludo@gnu.org>2018-10-29 00:13:38 +0100
commit63eb2b899be7ac857454442e09d0ebd23fe4f871 (patch)
tree4f80c7c62a093ff8cb389ca432d54d5984a66d26 /tests
parentb4c93a78c830a68d337598e7620adde64829bdb1 (diff)
downloadgnu-guix-63eb2b899be7ac857454442e09d0ebd23fe4f871.tar
gnu-guix-63eb2b899be7ac857454442e09d0ebd23fe4f871.tar.gz
Add 'guix processes'.
* guix/scripts/processes.scm, tests/processes.scm: New files. * Makefile.am (MODULES): Add the former. (SCM_TESTS): Add the latter. * po/guix/POTFILES.in: Add guix/scripts/processes.scm. * doc/guix.texi (Invoking guix processes): New node. (Invoking guix-daemon): Reference it.
Diffstat (limited to 'tests')
-rw-r--r--tests/processes.scm86
1 files changed, 86 insertions, 0 deletions
diff --git a/tests/processes.scm b/tests/processes.scm
new file mode 100644
index 0000000000..40454bcbc7
--- /dev/null
+++ b/tests/processes.scm
@@ -0,0 +1,86 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-processes)
+ #:use-module (guix scripts processes)
+ #:use-module (guix store)
+ #:use-module (guix derivations)
+ #:use-module (guix packages)
+ #:use-module (guix gexp)
+ #:use-module ((guix utils) #:select (call-with-temporary-directory))
+ #:use-module (gnu packages bootstrap)
+ #:use-module (guix tests)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-64)
+ #:use-module (rnrs bytevectors)
+ #:use-module (rnrs io ports)
+ #:use-module (ice-9 match)
+ #:use-module (ice-9 threads))
+
+(test-begin "processes")
+
+(test-assert "not a client"
+ (not (find (lambda (session)
+ (= (getpid)
+ (process-id (daemon-session-client session))))
+ (daemon-sessions))))
+
+(test-assert "client"
+ (with-store store
+ (let* ((session (find (lambda (session)
+ (= (getpid)
+ (process-id (daemon-session-client session))))
+ (daemon-sessions)))
+ (daemon (daemon-session-process session)))
+ (and (kill (process-id daemon) 0)
+ (string-suffix? "guix-daemon" (first (process-command daemon)))))))
+
+(test-assert "client + lock"
+ (with-store store
+ (call-with-temporary-directory
+ (lambda (directory)
+ (let* ((token1 (string-append directory "/token1"))
+ (token2 (string-append directory "/token2"))
+ (exp #~(begin #$(random-text)
+ (mkdir #$token1)
+ (let loop ()
+ (unless (file-exists? #$token2)
+ (sleep 1)
+ (loop)))
+ (mkdir #$output)))
+ (guile (package-derivation store %bootstrap-guile))
+ (drv (run-with-store store
+ (gexp->derivation "foo" exp
+ #:guile-for-build guile)))
+ (thread (call-with-new-thread
+ (lambda ()
+ (build-derivations store (list drv)))))
+ (_ (let loop ()
+ (unless (file-exists? token1)
+ (usleep 200)
+ (loop))))
+ (session (find (lambda (session)
+ (= (getpid)
+ (process-id (daemon-session-client session))))
+ (daemon-sessions)))
+ (locks (daemon-session-locks-held (pk 'session session))))
+ (call-with-output-file token2 (const #t))
+ (equal? (list (string-append (derivation->output-path drv) ".lock"))
+ locks))))))
+
+(test-end "processes")