summaryrefslogtreecommitdiff
path: root/tests/upstream.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-03-09 15:08:00 +0100
committerLudovic Courtès <ludo@gnu.org>2016-03-09 15:08:00 +0100
commitf1eacbafc4b98b8665856640c9d728372857eebf (patch)
treea32c7b47678d4f7b23b224762f1fdb101a381a03 /tests/upstream.scm
parent1ddee42472ecdad3d2dbbc2482aab5e3add3abdd (diff)
downloadgnu-guix-f1eacbafc4b98b8665856640c9d728372857eebf.tar
gnu-guix-f1eacbafc4b98b8665856640c9d728372857eebf.tar.gz
upstream: Fix 'signature-urls' coalescing.
Previously, the resulting 'signature-urls' would contain N times the same URL. * guix/upstream.scm (coalesce-sources): Fix TWO in 'signature-urls'. * tests/upstream.scm: New file. * Makefile.am (SCM_TESTS): Add it.
Diffstat (limited to 'tests/upstream.scm')
-rw-r--r--tests/upstream.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/tests/upstream.scm b/tests/upstream.scm
new file mode 100644
index 0000000000..eb18dd6193
--- /dev/null
+++ b/tests/upstream.scm
@@ -0,0 +1,49 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-upstream)
+ #:use-module (guix upstream)
+ #:use-module (guix tests)
+ #:use-module (srfi srfi-64))
+
+
+(test-begin "upstream")
+
+(test-equal "coalesce-sources same version"
+ (list (upstream-source
+ (package "foo") (version "1")
+ (urls '("ftp://example.org/foo-1.tar.xz"
+ "ftp://example.org/foo-1.tar.gz"))
+ (signature-urls '("ftp://example.org/foo-1.tar.xz.sig"
+ "ftp://example.org/foo-1.tar.gz.sig"))))
+
+ (coalesce-sources (list (upstream-source
+ (package "foo") (version "1")
+ (urls '("ftp://example.org/foo-1.tar.gz"))
+ (signature-urls
+ '("ftp://example.org/foo-1.tar.gz.sig")))
+ (upstream-source
+ (package "foo") (version "1")
+ (urls '("ftp://example.org/foo-1.tar.xz"))
+ (signature-urls
+ '("ftp://example.org/foo-1.tar.xz.sig"))))))
+
+(test-end)
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))