summaryrefslogtreecommitdiff
path: root/tests/system.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-21 22:45:54 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-22 00:02:52 +0100
commit6b779207ee627c93fc0dad18ef67c149024fa535 (patch)
tree9a4fa6759add87f0bcd943e72bddae960e749a82 /tests/system.scm
parent3738d8700ff84e16bfd8609efbd4db6933b414f1 (diff)
downloadgnu-guix-6b779207ee627c93fc0dad18ef67c149024fa535.tar
gnu-guix-6b779207ee627c93fc0dad18ef67c149024fa535.tar.gz
system: grub: Search root device by label or UUID if possible.
Fixes <http://bugs.gnu.org/22281>. Reported by Christopher Allan Webber <cwebber@dustycloud.org>. * gnu/system/grub.scm (eye-candy): Add 'root-fs' parameter. Replace 'search --file' command in the output with whatever 'grub-root-search' returns. (grub-root-search): New procedure. (grub-configuration-file): Add 'store-fs' parameter. Use 'grub-root-search' instead of hard-coded 'search --file' commands. * gnu/system.scm (store-file-system, operating-system-store-file-system): New procedures. (operating-system-grub.cfg): Use it, and adjust call to 'grub-configuration-file'. * tests/system.scm: New file. * Makefile.am (SCM_TESTS): Add it.
Diffstat (limited to 'tests/system.scm')
-rw-r--r--tests/system.scm77
1 files changed, 77 insertions, 0 deletions
diff --git a/tests/system.scm b/tests/system.scm
new file mode 100644
index 0000000000..7e016a610b
--- /dev/null
+++ b/tests/system.scm
@@ -0,0 +1,77 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-system)
+ #:use-module (gnu)
+ #:use-module (guix store)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-64))
+
+;; Test the (gnu system) module.
+
+(define %root-fs
+ (file-system
+ (device "my-root")
+ (title 'label)
+ (mount-point "/")
+ (type "ext4")))
+
+(define %os
+ (operating-system
+ (host-name "komputilo")
+ (timezone "Europe/Berlin")
+ (locale "en_US.utf8")
+ (bootloader (grub-configuration (device "/dev/sdX")))
+ (file-systems (cons %root-fs %base-file-systems))
+
+ (users %base-user-accounts)))
+
+(test-begin "system")
+
+(test-assert "operating-system-store-file-system"
+ ;; %BASE-FILE-SYSTEMS defines a bind-mount for /gnu/store, but this
+ ;; shouldn't be a problem.
+ (eq? %root-fs
+ (operating-system-store-file-system %os)))
+
+(test-assert "operating-system-store-file-system, prefix"
+ (let* ((gnu (file-system
+ (device "foobar")
+ (mount-point (dirname (%store-prefix)))
+ (type "ext5")))
+ (os (operating-system
+ (inherit %os)
+ (file-systems (cons* gnu %root-fs
+ %base-file-systems)))))
+ (eq? gnu (operating-system-store-file-system os))))
+
+(test-assert "operating-system-store-file-system, store"
+ (let* ((gnu (file-system
+ (device "foobar")
+ (mount-point (%store-prefix))
+ (type "ext5")))
+ (os (operating-system
+ (inherit %os)
+ (file-systems (cons* gnu %root-fs
+ %base-file-systems)))))
+ (eq? gnu (operating-system-store-file-system os))))
+
+(test-end)
+
+
+(exit (= (test-runner-fail-count (test-runner-current)) 0))