summaryrefslogtreecommitdiff
path: root/tests/status.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-01-18 23:21:29 +0100
committerLudovic Courtès <ludo@gnu.org>2018-09-27 23:21:53 +0200
commitdc0f74e5fc26977a3ee6c4f2aa74a141f4359982 (patch)
tree849de710a97637d1e830a15f630840e3af425d01 /tests/status.scm
parentfe65b559a671390ed5034d2d0b2c58c276e5abff (diff)
downloadgnu-guix-dc0f74e5fc26977a3ee6c4f2aa74a141f4359982.tar
gnu-guix-dc0f74e5fc26977a3ee6c4f2aa74a141f4359982.tar.gz
Add (guix status) and use it for pretty colored output.
* guix/progress.scm (progress-reporter/trace): New procedure. (%progress-interval): New variable. (progress-reporter/file): Use it. * guix/scripts/build.scm (set-build-options-from-command-line): Pass #:print-extended-build-trace?. (%default-options): Add 'print-extended-build-trace?'. (guix-build): Parameterize CURRENT-TERMINAL-COLUMNS. Use 'build-status-updater'. * guix/scripts/environment.scm (%default-options): Add 'print-extended-build-trace?'. (guix-environment): Wrap body in 'with-status-report'. * guix/scripts/pack.scm (%default-options): Add 'print-build-trace?' and 'print-extended-build-trace?'. (guix-pack): Wrap body in 'with-status-report'. * guix/scripts/package.scm (%default-options, guix-package): Likewise. * guix/scripts/system.scm (%default-options, guix-system): Likewise. * guix/scripts/pull.scm (%default-options, guix-pull): Likewise. * guix/scripts/substitute.scm (progress-report-port): Don't call STOP when TOTAL is zero. (process-substitution): Add #:print-build-trace? and honor it. (guix-substitute)[print-build-trace?]: New variable. Pass #:print-build-trace? to 'process-substitution'. * guix/status.scm: New file. * guix/store.scm (set-build-options): Add #:print-extended-build-trace?; pass it into PAIRS. (%protocol-version): Bump. (protocol-version, nix-server-version): New procedures. (current-store-protocol-version): New variable. (with-store, build-things): Parameterize it. * guix/ui.scm (build-output-port): Remove. (colorize-string): Export. * po/guix/POTFILES.in: Add guix/status.scm. * tests/status.scm: New file. * Makefile.am (SCM_TESTS): Add it. * nix/libstore/worker-protocol.hh (PROTOCOL_VERSION): Bump to 0x162. * nix/libstore/build.cc (DerivationGoal::registerOutputs) (SubstitutionGoal::finished): Print a "@ hash-mismatch" trace before throwing.
Diffstat (limited to 'tests/status.scm')
-rw-r--r--tests/status.scm115
1 files changed, 115 insertions, 0 deletions
diff --git a/tests/status.scm b/tests/status.scm
new file mode 100644
index 0000000000..04dedb702c
--- /dev/null
+++ b/tests/status.scm
@@ -0,0 +1,115 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (test-status)
+ #:use-module (guix status)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-11)
+ #:use-module (srfi srfi-64))
+
+(test-begin "status")
+
+(test-equal "compute-status, no-op"
+ (build-status)
+ (let-values (((port get-status)
+ (build-event-output-port compute-status)))
+ (display "foo\nbar\n\baz\n" port)
+ (get-status)))
+
+(test-equal "compute-status, builds + substitutes"
+ (list (build-status
+ (building '("foo.drv"))
+ (downloading (list (download "bar" "http://example.org/bar"
+ #:size 500
+ #:start 'now))))
+ (build-status
+ (building '("foo.drv"))
+ (downloading (list (download "bar" "http://example.org/bar"
+ #:size 500
+ #:transferred 42
+ #:start 'now))))
+ (build-status
+ (builds-completed '("foo.drv"))
+ (downloads-completed (list (download "bar" "http://example.org/bar"
+ #:size 500
+ #:transferred 500
+ #:start 'now
+ #:end 'now)))))
+ (let-values (((port get-status)
+ (build-event-output-port (lambda (event status)
+ (compute-status event status
+ #:current-time
+ (const 'now))))))
+ (display "@ build-started foo.drv\n" port)
+ (display "@ substituter-started bar\n" port)
+ (display "@ download-started bar http://example.org/bar 500\n" port)
+ (display "various\nthings\nget\nwritten\n" port)
+ (let ((first (get-status)))
+ (display "@ download-progress bar http://example.org/bar 500 42\n"
+ port)
+ (let ((second (get-status)))
+ (display "@ download-progress bar http://example.org/bar 500 84\n"
+ port)
+ (display "@ build-succeeded foo.drv\n" port)
+ (display "@ download-succeeded bar http://example.org/bar 500\n" port)
+ (display "Almost done!\n" port)
+ (display "@ substituter-succeeded bar\n" port)
+ (list first second (get-status))))))
+
+(test-equal "compute-status, missing events"
+ (list (build-status
+ (building '("foo.drv"))
+ (downloading (list (download "baz" "http://example.org/baz"
+ #:size 500
+ #:transferred 42
+ #:start 'now)
+ (download "bar" "http://example.org/bar"
+ #:size 999
+ #:transferred 0
+ #:start 'now))))
+ (build-status
+ (builds-completed '("foo.drv"))
+ (downloads-completed (list (download "baz" "http://example.org/baz"
+ #:size 500
+ #:transferred 500
+ #:start 'now
+ #:end 'now)
+ (download "bar" "http://example.org/bar"
+ #:size 999
+ #:transferred 999
+ #:start 'now
+ #:end 'now)))))
+ ;; Below we omit 'substituter-started' events and the like.
+ (let-values (((port get-status)
+ (build-event-output-port (lambda (event status)
+ (compute-status event status
+ #:current-time
+ (const 'now))))))
+ (display "@ build-started foo.drv\n" port)
+ (display "@ download-started bar http://example.org/bar 999\n" port)
+ (display "various\nthings\nget\nwritten\n" port)
+ (display "@ download-progress baz http://example.org/baz 500 42\n"
+ port)
+ (let ((first (get-status)))
+ (display "@ build-succeeded foo.drv\n" port)
+ (display "@ download-succeeded bar http://example.org/bar 999\n" port)
+ (display "Almost done!\n" port)
+ (display "@ substituter-succeeded baz\n" port)
+ (list first (get-status)))))
+
+(test-end "status")