summaryrefslogtreecommitdiff
path: root/tests/pypi.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-01-08 14:38:54 -0600
committerEric Bavier <bavier@member.fsf.org>2015-01-09 10:33:24 -0600
commit1ff2619bc114aface6b7b9d818f7208f9af677df (patch)
tree499f0d9f102b05bbb26e14a7a8e7b431231be509 /tests/pypi.scm
parentc6cb82f5d5739fcc84281e5dc91076c37f1db89c (diff)
downloadgnu-guix-1ff2619bc114aface6b7b9d818f7208f9af677df.tar
gnu-guix-1ff2619bc114aface6b7b9d818f7208f9af677df.tar.gz
import: Factorize utility functions.
* guix/import/pypi.scm (hash-table->alist, flatten, assoc-ref*, url-fetch, json-fetch): Pull procedures from here into... * guix/import/utils.scm: Here and... * guix/import/json.scm: Here. New file. * Makefile.am (MODULE)[HAVE_GUILE_JSON]: Add it. * guix/import/gnu.scm (file-sha256): Move from here to... * guix/hash.scm: Here. * tests/pypi.scm (pypi->guix-package): Update mock module reference.
Diffstat (limited to 'tests/pypi.scm')
-rw-r--r--tests/pypi.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/pypi.scm b/tests/pypi.scm
index 124c512d54..53c34d9e93 100644
--- a/tests/pypi.scm
+++ b/tests/pypi.scm
@@ -60,7 +60,7 @@
(test-assert "pypi->guix-package"
;; Replace network resources with sample data.
- (mock ((guix import pypi) url-fetch
+ (mock ((guix import utils) url-fetch
(lambda (url file-name)
(with-output-to-file file-name
(lambda ()