summaryrefslogtreecommitdiff
path: root/tests/guix-package.sh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-06 21:52:40 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-06 21:52:40 +0200
commit57b8623754fdd10b2cc194db09772f60010928af (patch)
tree273d4591f096d8ddf0f54feb5c23b104a8edd0db /tests/guix-package.sh
parent250bc998ac9d456f70c675579020d7173f87f3c3 (diff)
downloadgnu-guix-57b8623754fdd10b2cc194db09772f60010928af.tar
gnu-guix-57b8623754fdd10b2cc194db09772f60010928af.tar.gz
tests: Move 'guix package' tests that require networking to a separate file.
* tests/guix-package.sh (shebang_not_too_long): Remove. Move everything below "if [networking + shebang_not_too_long]" to... * tests/guix-package-net.sh: ... here. New file. * Makefile.am (SH_TESTS): Add it.
Diffstat (limited to 'tests/guix-package.sh')
-rw-r--r--tests/guix-package.sh138
1 files changed, 6 insertions, 132 deletions
diff --git a/tests/guix-package.sh b/tests/guix-package.sh
index a4c04255ba..6cfd50b5e5 100644
--- a/tests/guix-package.sh
+++ b/tests/guix-package.sh
@@ -28,14 +28,6 @@ readlink_base ()
basename `readlink "$1"`
}
-# Return true if a typical shebang in the store would not exceed Linux's
-# default static limit.
-shebang_not_too_long ()
-{
- test `echo $NIX_STORE_DIR/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa-bootstrap-binaries-0/bin/bash | wc -c` \
- -lt 128
-}
-
module_dir="t-guix-package-$$"
profile="t-profile-$$"
rm -f "$profile"
@@ -63,118 +55,12 @@ test -f "$profile/bin/guile"
guix package --search-paths -p "$profile"
test "`guix package --search-paths -p "$profile" | wc -l`" = 0
-# Check whether we have network access and an acceptable shebang length.
-if guile -c '(getaddrinfo "www.gnu.org" "80" AI_NUMERICSERV)' 2> /dev/null \
- && shebang_not_too_long
-then
- boot_make="(@@ (gnu packages commencement) gnu-make-boot0)"
- boot_make_drv="`guix build -e "$boot_make" | grep -v -e -debug`"
- guix package --bootstrap -p "$profile" -i "$boot_make_drv"
- test -L "$profile-2-link"
- test -f "$profile/bin/make" && test -f "$profile/bin/guile"
-
-
- # Check whether `--list-installed' works.
- # XXX: Change the tests when `--install' properly extracts the package
- # name and version string.
- installed="`guix package -p "$profile" --list-installed | cut -f1 | xargs echo | sort`"
- case "x$installed" in
- "guile-bootstrap make-boot0")
- true;;
- "make-boot0 guile-bootstrap")
- true;;
- "*")
- false;;
- esac
-
- test "`guix package -p "$profile" -I 'g.*e' | cut -f1`" = "guile-bootstrap"
-
- # List generations.
- test "`guix package -p "$profile" -l | cut -f1 | grep guile | head -n1`" \
- = " guile-bootstrap"
-
- # Exit with 1 when a generation does not exist.
- if guix package -p "$profile" --list-generations=42;
- then false; else true; fi
- if guix package -p "$profile" --switch-generation=99;
- then false; else true; fi
-
- # Remove a package.
- guix package --bootstrap -p "$profile" -r "guile-bootstrap"
- test -L "$profile-3-link"
- test -f "$profile/bin/make" && ! test -f "$profile/bin/guile"
-
- # Roll back.
- guix package --roll-back -p "$profile"
- test "`readlink_base "$profile"`" = "$profile-2-link"
- test -x "$profile/bin/guile" && test -x "$profile/bin/make"
- guix package --roll-back -p "$profile"
- test "`readlink_base "$profile"`" = "$profile-1-link"
- test -x "$profile/bin/guile" && ! test -x "$profile/bin/make"
-
- # Switch to the rolled generation and switch back.
- guix package -p "$profile" --switch-generation=2
- test "`readlink_base "$profile"`" = "$profile-2-link"
- guix package -p "$profile" --switch-generation=-1
- test "`readlink_base "$profile"`" = "$profile-1-link"
-
- # Move to the empty profile.
- for i in `seq 1 3`
- do
- guix package --bootstrap --roll-back -p "$profile"
- ! test -f "$profile/bin"
- ! test -f "$profile/lib"
- test "`readlink_base "$profile"`" = "$profile-0-link"
- done
-
- # Test that '--list-generations' does not output the zeroth generation.
- test -z "`guix package -p "$profile" -l 0`"
-
- # Reinstall after roll-back to the empty profile.
- guix package --bootstrap -p "$profile" -e "$boot_make"
- test "`readlink_base "$profile"`" = "$profile-1-link"
- test -x "$profile/bin/guile" && ! test -x "$profile/bin/make"
-
- # Check that the first generation is the current one.
- test "`guix package -p "$profile" -l 1 | cut -f3 | head -n1`" = "(current)"
-
- # Roll-back to generation 0, and install---all at once.
- guix package --bootstrap -p "$profile" --roll-back -i guile-bootstrap
- test "`readlink_base "$profile"`" = "$profile-1-link"
- test -x "$profile/bin/guile" && ! test -x "$profile/bin/make"
-
- # Install Make.
- guix package --bootstrap -p "$profile" -e "$boot_make"
- test "`readlink_base "$profile"`" = "$profile-2-link"
- test -x "$profile/bin/guile" && test -x "$profile/bin/make"
- grep "`guix build -e "$boot_make"`" "$profile/manifest"
-
- # Make a "hole" in the list of generations, and make sure we can
- # roll back and switch "over" it.
- rm "$profile-1-link"
- guix package --bootstrap -p "$profile" --roll-back
- test "`readlink_base "$profile"`" = "$profile-0-link"
- guix package -p "$profile" --switch-generation=+1
- test "`readlink_base "$profile"`" = "$profile-2-link"
-
- # Make sure LIBRARY_PATH gets listed by `--search-paths'.
- guix package --bootstrap -p "$profile" -i guile-bootstrap -i gcc-bootstrap
- guix package --search-paths -p "$profile" | grep LIBRARY_PATH
-
- # Roll back so we can delete #3 below.
- guix package -p "$profile" --switch-generation=2
-
- # Delete the third generation and check that it was actually deleted.
- guix package -p "$profile" --delete-generations=3
- test -z "`guix package -p "$profile" -l 3`"
-
- # Exit with 1 when a generation does not exist.
- if guix package -p "$profile" --delete-generations=42;
- then false; else true; fi
-
- # Exit with 0 when trying to delete the zeroth generation.
- guix package -p "$profile" --delete-generations=0
-fi
+# Exit with 1 when a generation does not exist.
+if guix package -p "$profile" --delete-generations=42;
+then false; else true; fi
+
+# Exit with 0 when trying to delete the zeroth generation.
+guix package -p "$profile" --delete-generations=0
# Make sure multiple arguments to -i works.
guix package --bootstrap -i guile gcc -p "$profile" -n
@@ -253,18 +139,6 @@ guix package --bootstrap -i guile-bootstrap
test -L "$HOME/.guix-profile"
test -f "$HOME/.guix-profile/bin/guile"
-if guile -c '(getaddrinfo "www.gnu.org" "80" AI_NUMERICSERV)' 2> /dev/null
-then
- guix package --bootstrap -e "$boot_make"
- test -f "$HOME/.guix-profile/bin/make"
- first_environment="`cd $HOME/.guix-profile ; pwd`"
-
- guix package --bootstrap --roll-back
- test -f "$HOME/.guix-profile/bin/guile"
- ! test -f "$HOME/.guix-profile/bin/make"
- test "`cd $HOME/.guix-profile ; pwd`" = "$first_environment"
-fi
-
# Move to the empty profile.
default_profile="`readlink "$HOME/.guix-profile"`"
for i in `seq 1 3`