summaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-31 00:22:39 +0100
committerLudovic Courtès <ludo@gnu.org>2012-10-31 00:22:39 +0100
commitf03da4a0086a937409d07b27b3dac3b2e60cc0d4 (patch)
tree81f5fb163804814787dba5be24f8e2728a14dbb4 /release.nix
parent34811f02bf176c307ebe329aaefab8ed616a10df (diff)
downloadgnu-guix-f03da4a0086a937409d07b27b3dac3b2e60cc0d4.tar
gnu-guix-f03da4a0086a937409d07b27b3dac3b2e60cc0d4.tar.gz
release.nix: Use `--no-substitutes' in `distro.hello'.
* release.nix (distro.hello): Use `guix-build --no-substitutes', to avoid failures due to unavailable stale substitutes on hydra.nixos.org.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index 70c9269017..05a14a89cf 100644
--- a/release.nix
+++ b/release.nix
@@ -97,7 +97,7 @@ let
pkgs = import nixpkgs { inherit system; };
guix = jobs.build { inherit system; };
in
- # XXX: We have no way to tell the Nix to swallow the .drv
+ # XXX: We have no way to tell the Nix code to swallow the .drv
# produced by `guix-build', so we have a pointless indirection
# here. This could be worked around by generating Nix code
# from the .drv, and importing that.
@@ -105,7 +105,7 @@ let
src = null;
name = "guix-hello";
phases = "buildPhase";
- buildPhase = "${guix}/bin/guix-build hello | tee $out";
+ buildPhase = "${guix}/bin/guix-build --no-substitutes hello | tee $out";
__noChroot = true;
};
};