summaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:02 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-03 21:11:26 +0100
commite76bdf8b87920b87a2a2e728c2e40ff24ca39ffe (patch)
treeffcb4e08f2d00acaf670c8344e6a12da6ea39772 /release.nix
parent81dbd783bd9afabd1d8720c9b60a6a93492bb581 (diff)
downloadgnu-guix-e76bdf8b87920b87a2a2e728c2e40ff24ca39ffe.tar
gnu-guix-e76bdf8b87920b87a2a2e728c2e40ff24ca39ffe.tar.gz
build: Clearly mark Nixpkgs as optional.
* configure.ac: Always show the result of checking for Nixpkgs. Don't warn when Nixpkgs is not found. * Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Remove `--with-nixpkgs' flag. * guix/utils.scm (%nixpkgs-directory): Use either the compile-time or the run-time `NIXPKGS' environment variable. * release.nix (jobs.tarball, jobs.build): Remove `--with-nixpkgs' configure flag. * README: Mark Nixpkgs as optional. * distro/packages/databases.scm, distro/packages/guile.scm, distro/packages/typesetting.scm: Change uses of `nixpkgs-derivation*' to `nixpkgs-derivation', to avoid failing at compile-time.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index 05a14a89cf..67e096ffc1 100644
--- a/release.nix
+++ b/release.nix
@@ -51,7 +51,7 @@ let
buildInputs = with pkgs; [ guile ];
buildNativeInputs = with pkgs; [ texinfo gettext cvs pkgconfig ];
configureFlags =
- [ "--with-nixpkgs=${nixpkgs}" "--with-nix-prefix=${pkgs.nix}" ];
+ [ "--with-nix-prefix=${pkgs.nix}" ];
};
build =
@@ -64,7 +64,7 @@ let
buildNativeInputs = [ pkgs.pkgconfig ];
src = jobs.tarball;
configureFlags =
- [ "--with-nixpkgs=${nixpkgs}" "--with-nix-prefix=${pkgs.nix}"
+ [ "--with-nix-prefix=${pkgs.nix}"
"--with-libgcrypt-prefix=${pkgs.libgcrypt}"
];