summaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-18 23:17:28 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-18 23:17:28 +0100
commitce41a4629ce6e9502d62b617dd1a74d646ad5b43 (patch)
treeb9925f999ea1474f158e53258a8031d1e72977b9 /release.nix
parent9c3ac1b641379cf7331804aca668c6d46b5ec722 (diff)
downloadgnu-guix-ce41a4629ce6e9502d62b617dd1a74d646ad5b43.tar
gnu-guix-ce41a4629ce6e9502d62b617dd1a74d646ad5b43.tar.gz
release.nix: Hack to unchroot more stuff.
* release.nix (unchrootedNixpkgs): New function. (jobs)[tarball, build, build_disable_daemon, distro): Use it. Should fix <http://hydra.gnu.org:3000/build/7279>.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix19
1 files changed, 15 insertions, 4 deletions
diff --git a/release.nix b/release.nix
index 793daa77f6..86560ea15a 100644
--- a/release.nix
+++ b/release.nix
@@ -48,6 +48,17 @@ let
})
else drv;
+ # Return a Nixpkgs with some derivations "unchrooted".
+ unchrootedNixpkgs = system:
+ import nixpkgs {
+ # XXX: Hack to make sure these ones also get "unchrooted".
+ config.packageOverrides = pkgs: {
+ zlib = unchroot pkgs.zlib;
+ libunistring = unchroot pkgs.libunistring;
+ };
+ inherit system;
+ };
+
# The Guile used to bootstrap the whole thing. It's normally
# downloaded by the build system, but here we download it via a
# fixed-output derivation and stuff it into the build tree.
@@ -67,7 +78,7 @@ let
jobs = {
tarball =
unchroot
- (let pkgs = import nixpkgs {}; in
+ (let pkgs = unchrootedNixpkgs builtins.currentSystem; in
pkgs.releaseTools.sourceTarball {
name = "guix-tarball";
src = <guix>;
@@ -94,7 +105,7 @@ let
{ system ? builtins.currentSystem }:
unchroot
- (let pkgs = import nixpkgs { inherit system; }; in
+ (let pkgs = unchrootedNixpkgs system; in
pkgs.releaseTools.nixBuild {
name = "guix";
buildInputs = with pkgs; [ guile sqlite bzip2 libgcrypt ];
@@ -125,7 +136,7 @@ let
unchroot
(let
- pkgs = import nixpkgs { inherit system; };
+ pkgs = unchrootedNixpkgs system;
build = jobs.build { inherit system; };
in
pkgs.lib.overrideDerivation build ({ configureFlags, ... }: {
@@ -144,7 +155,7 @@ let
{ system ? builtins.currentSystem }:
let
- pkgs = import nixpkgs { inherit system; };
+ pkgs = unchrootedNixpkgs system;
guix = jobs.build { inherit system; };
in
# XXX: We have no way to tell the Nix code to swallow the .drv