summaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-13 22:08:33 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-13 22:08:33 +0100
commitb35c0f866c83288e64dcf5839d908705d416c317 (patch)
tree1d772877d14523934dc36c5ff04891f1402e4a3f /release.nix
parent6a95fa501f1d399433c56e2ee9fc2c52f79119df (diff)
downloadgnu-guix-b35c0f866c83288e64dcf5839d908705d416c317.tar
gnu-guix-b35c0f866c83288e64dcf5839d908705d416c317.tar.gz
release.nix: Add `build_disable_daemon'.
* release.nix (build_disable_daemon): New job.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index 4c54f75b0a..2d3a70f524 100644
--- a/release.nix
+++ b/release.nix
@@ -86,6 +86,23 @@ let
};
+ build_disable_daemon =
+ { system ? builtins.currentSystem }:
+
+ let
+ pkgs = import nixpkgs { inherit system; };
+ build = jobs.build { inherit system; };
+ in
+ pkgs.lib.overrideDerivation build ({ configureFlags, ... }: {
+ configureFlags = configureFlags ++ [ "--disable-daemon" ];
+ buildInputs = with pkgs; [ guile nixUnstable pkgconfig ];
+
+ # Since we need to talk to a running daemon, we need to escape
+ # the chroot.
+ preConfigure = "export NIX_REMOTE=daemon";
+ __noChroot = true;
+ });
+
# Jobs to test the distro.
distro = {
hello =