summaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-03-18 23:07:42 +0100
committerLudovic Courtès <ludo@gnu.org>2013-03-18 23:09:35 +0100
commit9c3ac1b641379cf7331804aca668c6d46b5ec722 (patch)
treee76d27b51e89beaffe8487bf9d5fb7b63d041202 /release.nix
parenta4f08f9258805bf3d783db9a20d66d60209d8853 (diff)
downloadgnu-guix-9c3ac1b641379cf7331804aca668c6d46b5ec722.tar
gnu-guix-9c3ac1b641379cf7331804aca668c6d46b5ec722.tar.gz
release.nix: Adjust to current Nixpkgs.
* release.nix: s/buildNativeInputs/nativeBuildInputs/.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/release.nix b/release.nix
index 5aab8600ab..793daa77f6 100644
--- a/release.nix
+++ b/release.nix
@@ -42,9 +42,9 @@ let
if builtins.isAttrs drv
then pkgs.lib.overrideDerivation (pythonKludge drv) (args: {
__noChroot = true;
- buildNativeInputs = map unchroot args.buildNativeInputs;
- propagatedBuildNativeInputs =
- map unchroot args.propagatedBuildNativeInputs;
+ nativeBuildInputs = map unchroot args.nativeBuildInputs;
+ propagatedNativeBuildInputs =
+ map unchroot args.propagatedNativeBuildInputs;
})
else drv;
@@ -82,7 +82,7 @@ let
in
[ git_light ] ++
(with pkgs; [ guile sqlite bzip2 libgcrypt ]);
- buildNativeInputs = with pkgs; [ texinfo gettext cvs pkgconfig ];
+ nativeBuildInputs = with pkgs; [ texinfo gettext cvs pkgconfig ];
preAutoconf = ''git config submodule.nix.url "${<nix>}"'';
configureFlags =
[ "--with-libgcrypt-prefix=${pkgs.libgcrypt}"
@@ -98,7 +98,7 @@ let
pkgs.releaseTools.nixBuild {
name = "guix";
buildInputs = with pkgs; [ guile sqlite bzip2 libgcrypt ];
- buildNativeInputs = [ pkgs.pkgconfig ];
+ nativeBuildInputs = [ pkgs.pkgconfig ];
src = jobs.tarball;
configureFlags =
[ "--with-libgcrypt-prefix=${pkgs.libgcrypt}"