summaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-27 23:19:46 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-27 23:19:46 +0200
commit9144af5aa7b757b1dacd3f39ebdac8a31bc36e9f (patch)
treeb96daa599a71d86630d73746e2a0878ed3bdfb97 /release.nix
parent5992f213d79a5fe8568b3029f9397646a34b8871 (diff)
downloadgnu-guix-9144af5aa7b757b1dacd3f39ebdac8a31bc36e9f.tar
gnu-guix-9144af5aa7b757b1dacd3f39ebdac8a31bc36e9f.tar.gz
release.nix: Add a `distro.hello' job.
* release.nix (distro.hello): New job.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/release.nix b/release.nix
index 39a628975a..1f31ffc6a5 100644
--- a/release.nix
+++ b/release.nix
@@ -86,6 +86,29 @@ let
inherit succeedOnFailure keepBuildDirectory
buildOutOfSourceTree;
};
+
+
+ # Jobs to test the distro.
+ distro = {
+ hello =
+ { system ? builtins.currentSystem }:
+
+ let
+ pkgs = import nixpkgs { inherit system; };
+ guix = jobs.build { inherit system; };
+ in
+ # XXX: We have no way to tell the Nix to swallow the .drv
+ # produced by `guix-build', so we have a pointless indirection
+ # here. This could be worked around by generating Nix code
+ # from the .drv, and importing that.
+ pkgs.releaseTools.nixBuild {
+ src = null;
+ phases = "buildPhase";
+ buildInputs = [ guix ];
+ buildPhase = "guix-build hello";
+ __noChroot = true;
+ };
+ };
};
in
jobs