summaryrefslogtreecommitdiff
path: root/release.nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-10-28 02:02:04 +0200
committerLudovic Courtès <ludo@gnu.org>2012-10-28 02:02:04 +0200
commit48da001fd96bb9ff063b512666f5122b83bc210d (patch)
tree1d336ee4d4a00afd725c1e6eb5004482eef3c5b3 /release.nix
parentd6ed71cbf4cdf01f69189459e782fabdf0f92525 (diff)
downloadgnu-guix-48da001fd96bb9ff063b512666f5122b83bc210d.tar
gnu-guix-48da001fd96bb9ff063b512666f5122b83bc210d.tar.gz
release.nix: Change `distro.hello' to produce something.
* release.nix (distro.hello)[buildPhase]: Tee the log to $out. Add a `name' attribute; remove `buildInputs' and instead use the full path to `guix-build'.
Diffstat (limited to 'release.nix')
-rw-r--r--release.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/release.nix b/release.nix
index 1f31ffc6a5..70c9269017 100644
--- a/release.nix
+++ b/release.nix
@@ -103,9 +103,9 @@ let
# from the .drv, and importing that.
pkgs.releaseTools.nixBuild {
src = null;
+ name = "guix-hello";
phases = "buildPhase";
- buildInputs = [ guix ];
- buildPhase = "guix-build hello";
+ buildPhase = "${guix}/bin/guix-build hello | tee $out";
__noChroot = true;
};
};