summaryrefslogtreecommitdiff
path: root/po
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-11-28 22:20:08 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-11-28 22:23:55 +0100
commit7565d40e1e583b35148088bcf79760b9f95f91d9 (patch)
tree017e4e1b5095450e75c89709e4ab9d0a5f9e9eff /po
parenta5d474d798b5f3071017ff32aade11bc3ebe9150 (diff)
downloadgnu-guix-7565d40e1e583b35148088bcf79760b9f95f91d9.tar
gnu-guix-7565d40e1e583b35148088bcf79760b9f95f91d9.tar.gz
nls: Update documentation po and pot with `make dist`.
* Makefile.am: dist-hook depends on doc-po-update. * po/doc/local.mk (doc-po-update): New target.
Diffstat (limited to 'po')
-rw-r--r--po/doc/local.mk12
1 files changed, 10 insertions, 2 deletions
diff --git a/po/doc/local.mk b/po/doc/local.mk
index 3d3b4f67b1..6b934d945a 100644
--- a/po/doc/local.mk
+++ b/po/doc/local.mk
@@ -16,11 +16,14 @@
# You should have received a copy of the GNU General Public License
# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-EXTRA_DIST = \
- %D%/guix-manual.pot \
+DOC_PO_FILES= \
%D%/guix-manual.de.po \
%D%/guix-manual.fr.po
+EXTRA_DIST = \
+ %D%/guix-manual.pot \
+ $(DOC_PO_FILES)
+
POT_OPTIONS = --package-name "guix" --package-version "$(VERSION)" \
--copyright-holder "Ludovic Courtès" \
--msgid-bugs-address "ludo@gnu.org"
@@ -58,3 +61,8 @@ doc-pot-update:
done
msgcat $(addprefix $(srcdir)/po/doc/, $(TMP_POT_FILES)) > $(srcdir)/po/doc/guix-manual.pot
rm -f $(addprefix $(srcdir)/po/doc/, $(TMP_POT_FILES))
+
+doc-po-update: doc-pot-update
+ for f in $(DOC_PO_FILES); do \
+ $(MAKE) "$$f"; \
+ done