summaryrefslogtreecommitdiff
path: root/nix
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-03-05 14:33:13 -0500
committerLeo Famulari <leo@famulari.name>2017-03-06 13:25:51 -0500
commit613d0895b92c677e0639d5e77c55043e38e020c8 (patch)
tree5f2600f6c1fdf0648d310d7198772a34b5286c8a /nix
parentb812da70594f5d40647d156f69be0eb169d6be19 (diff)
downloadgnu-guix-613d0895b92c677e0639d5e77c55043e38e020c8.tar
gnu-guix-613d0895b92c677e0639d5e77c55043e38e020c8.tar.gz
build: Don't embed absolute paths in .service and .conf service files.
Otherwise, users will be stuck running an old copy of guix and the guix-daemon if they copy the service files instead of symlinking them. * etc/guix-daemon.conf.in, etc/guix-daemon.service.in, etc/guix-publish.conf.in, etc/guix-publish.service.in: Expand @localstatedir@ instead of @bindir@. * nix/local.mk (etc/guix-%.service, etc/guix-%.conf): Use @localstatedir@ instead of @bindir@.
Diffstat (limited to 'nix')
-rw-r--r--nix/local.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/nix/local.mk b/nix/local.mk
index eb70d266fb..9e0c457bec 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -190,7 +190,7 @@ nodist_systemdservice_DATA = etc/guix-daemon.service etc/guix-publish.service
etc/guix-%.service: etc/guix-%.service.in \
$(top_builddir)/config.status
$(AM_V_GEN)$(MKDIR_P) "`dirname $@`"; \
- $(SED) -e 's|@''bindir''@|$(bindir)|' < \
+ $(SED) -e 's|@''localstatedir''@|$(localstatedir)|' < \
"$<" > "$@.tmp"; \
mv "$@.tmp" "$@"
@@ -201,7 +201,7 @@ nodist_upstartjob_DATA = etc/guix-daemon.conf etc/guix-publish.conf
etc/guix-%.conf: etc/guix-%.conf.in \
$(top_builddir)/config.status
$(AM_V_GEN)$(MKDIR_P) "`dirname $@`"; \
- $(SED) -e 's|@''bindir''@|$(bindir)|' < \
+ $(SED) -e 's|@''localstatedir''@|$(localstatedir)|' < \
"$<" > "$@.tmp"; \
mv "$@.tmp" "$@"