summaryrefslogtreecommitdiff
path: root/nix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-04 15:40:09 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-14 11:16:58 +0200
commit3931c76154d4f418d5ea9acc5e47bf911d371c24 (patch)
treee0df9932162f11fbd4cc60f78baee7d283658671 /nix
parent03439df66fc2699b22e5786b33324e5432cfe8cf (diff)
downloadgnu-guix-3931c76154d4f418d5ea9acc5e47bf911d371c24.tar
gnu-guix-3931c76154d4f418d5ea9acc5e47bf911d371c24.tar.gz
database: 'with-database' can now initialize new databases.
* nix/libstore/schema.sql: Rename to... * guix/store/schema.sql: ... this. * Makefile.am (nobase_dist_guilemodule_DATA): Add it. * nix/local.mk (%D%/libstore/schema.sql.hh): Adjust accordingly. * guix/store/database.scm (sql-schema): New variable. (sqlite-exec, initialize-database, call-with-database): New procedures. (with-database): Rewrite in terms of 'call-with-database'. * tests/store-database.scm ("new database"): New test. * guix/self.scm (compiled-guix)[*core-modules*]: Add 'schema.sql' to #:extra-files.
Diffstat (limited to 'nix')
-rw-r--r--nix/libstore/schema.sql44
-rw-r--r--nix/local.mk2
2 files changed, 1 insertions, 45 deletions
diff --git a/nix/libstore/schema.sql b/nix/libstore/schema.sql
deleted file mode 100644
index c1b4a689af..0000000000
--- a/nix/libstore/schema.sql
+++ /dev/null
@@ -1,44 +0,0 @@
-create table if not exists ValidPaths (
- id integer primary key autoincrement not null,
- path text unique not null,
- hash text not null,
- registrationTime integer not null,
- deriver text,
- narSize integer
-);
-
-create table if not exists Refs (
- referrer integer not null,
- reference integer not null,
- primary key (referrer, reference),
- foreign key (referrer) references ValidPaths(id) on delete cascade,
- foreign key (reference) references ValidPaths(id) on delete restrict
-);
-
-create index if not exists IndexReferrer on Refs(referrer);
-create index if not exists IndexReference on Refs(reference);
-
--- Paths can refer to themselves, causing a tuple (N, N) in the Refs
--- table. This causes a deletion of the corresponding row in
--- ValidPaths to cause a foreign key constraint violation (due to `on
--- delete restrict' on the `reference' column). Therefore, explicitly
--- get rid of self-references.
-create trigger if not exists DeleteSelfRefs before delete on ValidPaths
- begin
- delete from Refs where referrer = old.id and reference = old.id;
- end;
-
-create table if not exists DerivationOutputs (
- drv integer not null,
- id text not null, -- symbolic output id, usually "out"
- path text not null,
- primary key (drv, id),
- foreign key (drv) references ValidPaths(id) on delete cascade
-);
-
-create index if not exists IndexDerivationOutputs on DerivationOutputs(path);
-
-create table if not exists FailedPaths (
- path text primary key not null,
- time integer not null
-);
diff --git a/nix/local.mk b/nix/local.mk
index 39717711f8..b4c6ba61a4 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -163,7 +163,7 @@ noinst_HEADERS = \
$(libformat_headers) $(libutil_headers) $(libstore_headers) \
$(guix_daemon_headers)
-%D%/libstore/schema.sql.hh: %D%/libstore/schema.sql
+%D%/libstore/schema.sql.hh: guix/store/schema.sql
$(AM_V_GEN)$(GUILE) --no-auto-compile -c \
"(use-modules (rnrs io ports)) \
(call-with-output-file \"$@\" \