summaryrefslogtreecommitdiff
path: root/nix
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-24 09:23:11 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-24 09:23:11 +0100
commit332d7903f52c2bf3741b04ac2d01cd9018b70800 (patch)
tree86c36b8ebda45fb0f284b8aca1dd9b3f15cf340c /nix
parentb7230de54b493da5a78922b4226255763b525a98 (diff)
downloadgnu-guix-332d7903f52c2bf3741b04ac2d01cd9018b70800.tar
gnu-guix-332d7903f52c2bf3741b04ac2d01cd9018b70800.tar.gz
Add system start-up files for "guix publish".
* .gitignore: add etc/guix-publish.conf and /etc/guix-publish.service. * etc/guix-publish.conf.in: New file. * etc/guix-publish.service.in: New file. * nix/local.mk (etc/guix-%.service, etc/guix-%.conf): Generalized former build-rules for by using patterns. (nodist_systemdservice_DATA): Add etc/guix-publish.service, update comment. (nodist_upstartjob_DATA): Add etc/guix-publish.conf, update comment. * doc/guix.texi (Invoking guix publish): Add description for enabling "guix publish" on host distros using the new files.
Diffstat (limited to 'nix')
-rw-r--r--nix/local.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/nix/local.mk b/nix/local.mk
index 86ef769549..79667ed49e 100644
--- a/nix/local.mk
+++ b/nix/local.mk
@@ -183,26 +183,26 @@ endif BUILD_DAEMON_OFFLOAD
nodist_libexec_SCRIPTS = \
%D%/scripts/guix-authenticate
-# The '.service' file for systemd.
+# The '.service' files for systemd.
systemdservicedir = $(libdir)/systemd/system
-nodist_systemdservice_DATA = etc/guix-daemon.service
+nodist_systemdservice_DATA = etc/guix-daemon.service etc/guix-publish.service
-etc/guix-daemon.service: etc/guix-daemon.service.in \
+etc/guix-%.service: etc/guix-%.service.in \
$(top_builddir)/config.status
$(AM_V_GEN)$(MKDIR_P) "`dirname $@`"; \
$(SED) -e 's|@''bindir''@|$(bindir)|' < \
- "$(srcdir)/etc/guix-daemon.service.in" > "$@.tmp"; \
+ "$(srcdir)/$<" > "$@.tmp"; \
mv "$@.tmp" "$@"
-# The '.conf' job for Upstart.
+# The '.conf' jobs for Upstart.
upstartjobdir = $(libdir)/upstart/system
-nodist_upstartjob_DATA = etc/guix-daemon.conf
+nodist_upstartjob_DATA = etc/guix-daemon.conf etc/guix-publish.conf
-etc/guix-daemon.conf: etc/guix-daemon.conf.in \
+etc/guix-%.conf: etc/guix-%.conf.in \
$(top_builddir)/config.status
$(AM_V_GEN)$(MKDIR_P) "`dirname $@`"; \
$(SED) -e 's|@''bindir''@|$(bindir)|' < \
- "$(srcdir)/etc/guix-daemon.conf.in" > "$@.tmp"; \
+ "$(srcdir)/$<" > "$@.tmp"; \
mv "$@.tmp" "$@"
EXTRA_DIST += \