summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-06-27 23:58:07 +0200
committerLudovic Courtès <ludo@gnu.org>2012-06-27 23:58:07 +0200
commit208f7cd155abdf07ae4f858aeeb26892eb08df88 (patch)
treea6fc59bd1ae85e9f2929ee2079cc90539193e476 /guix
parent72d869634bd22d978af13f5a8c89ddff27140422 (diff)
downloadgnu-guix-208f7cd155abdf07ae4f858aeeb26892eb08df88.tar
gnu-guix-208f7cd155abdf07ae4f858aeeb26892eb08df88.tar.gz
Abstract build systems.
* Makefile.am (MODULES): Add `guix/build-system.scm' and `guix/build-system/gnu.scm'. Remove `guix/gnu-build-system.scm'. * guix/build-system.scm: New file. * guix/gnu-build-system.scm: Rename to... * guix/build-system/gnu.scm: ... this. (gnu-build-system): New variable. * tests/builders.scm: Adjust `use-module' clauses. ("gnu-build-system"): New test.
Diffstat (limited to 'guix')
-rw-r--r--guix/build-system.scm34
-rw-r--r--guix/build-system/gnu.scm (renamed from guix/gnu-build-system.scm)12
2 files changed, 44 insertions, 2 deletions
diff --git a/guix/build-system.scm b/guix/build-system.scm
new file mode 100644
index 0000000000..179e7ef2df
--- /dev/null
+++ b/guix/build-system.scm
@@ -0,0 +1,34 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build-system)
+ #:use-module (guix utils)
+ #:export (build-system
+ build-system?
+ build-system-name
+ build-system-description
+ build-system-builder
+ build-system-cross-builder))
+
+(define-record-type* <build-system> build-system make-build-system
+ build-system?
+ (name build-system-name) ; symbol
+ (description build-system-description) ; short description
+ (build build-system-builder) ; (store system name source inputs)
+ (cross-build build-system-cross-builder ; (store system x-system ...)
+ (default #f)))
diff --git a/guix/gnu-build-system.scm b/guix/build-system/gnu.scm
index 0311aaa76f..e9eb02f251 100644
--- a/guix/gnu-build-system.scm
+++ b/guix/build-system/gnu.scm
@@ -16,12 +16,14 @@
;;; You should have received a copy of the GNU General Public License
;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
-(define-module (guix gnu-build-system)
+(define-module (guix build-system gnu)
#:use-module (guix store)
#:use-module (guix utils)
#:use-module (guix derivations)
+ #:use-module (guix build-system)
#:use-module (srfi srfi-1)
- #:export (gnu-build))
+ #:export (gnu-build
+ gnu-build-system))
;; Commentary:
;;
@@ -63,3 +65,9 @@ input derivation INPUTS, using the usual procedure of the GNU Build System."
#:outputs outputs
#:modules '((guix build gnu-build-system)
(guix build utils))))
+
+(define gnu-build-system
+ (build-system (name 'gnu)
+ (description
+ "The GNU Build System—i.e., ./configure && make && make install")
+ (build gnu-build))) ; TODO: add `gnu-cross-build'