summaryrefslogtreecommitdiff
path: root/guix/store
diff options
context:
space:
mode:
authorLudovic Courtès <ludovic.courtes@inria.fr>2017-04-21 19:13:32 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-21 19:17:36 +0200
commit285f63e805f4a895c1d301efe6d40e93c4e2f704 (patch)
treeabe2a16994bc1362ad6b51a3d8a1efcd1f092c57 /guix/store
parente537833726cb093f101566793e083098d04ac58b (diff)
downloadgnu-guix-285f63e805f4a895c1d301efe6d40e93c4e2f704.tar
gnu-guix-285f63e805f4a895c1d301efe6d40e93c4e2f704.tar.gz
store: Support 'ssh://' URIs in 'GUIX_DAEMON_SOCKET'.
This allows 'guix' commands to talk to a remote store over SSH. * guix/store.scm (connect-to-daemon)[connect]: Call 'resolve-interface' for unknown URI schemes. * guix/store/ssh.scm: New file. * Makefile.am (MODULES): Add it. * doc/guix.texi (The Store): Document it. Mark remote access as experimental.
Diffstat (limited to 'guix/store')
-rw-r--r--guix/store/ssh.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/guix/store/ssh.scm b/guix/store/ssh.scm
new file mode 100644
index 0000000000..09c0832505
--- /dev/null
+++ b/guix/store/ssh.scm
@@ -0,0 +1,39 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix store ssh)
+ #:use-module (guix ssh)
+ #:use-module (web uri)
+ #:export (connect-to-daemon))
+
+;;; Commentary:
+;;;
+;;; This modules provides the entry point for 'open-connection' in (guix
+;;; store). Passing an 'ssh://' URI to 'open-connection' triggers the use of
+;;; the code in this module.
+;;;
+;;; End:
+
+(define (connect-to-daemon uri)
+ "Connect to the SSH daemon at URI, a URI object with the 'ssh' scheme."
+ (remote-daemon-channel
+ (open-ssh-session (uri-host uri)
+ #:port (or (uri-port uri) 22)
+ #:user (uri-userinfo uri))))
+
+;;; ssh.scm ends here