summaryrefslogtreecommitdiff
path: root/guix/store.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-06-28 10:13:45 +0200
committerLudovic Courtès <ludo@gnu.org>2017-12-12 18:11:22 +0100
commit03870da81922ccb6cc1a91976487f2d3f7da0d81 (patch)
treefe93a2ae9f7fc0c3ba124961cce48b76fdd9eae3 /guix/store.scm
parent6e119bad60b3c1aa3b13f5b6d7e8c2987d3453d0 (diff)
downloadgnu-guix-03870da81922ccb6cc1a91976487f2d3f7da0d81.tar
gnu-guix-03870da81922ccb6cc1a91976487f2d3f7da0d81.tar.gz
Add (guix profiling).
* guix/profiling.scm: New file. * Makefile.am (MODULES): Add it. * guix/store.scm (record-operation): Use 'profiled?' and 'register-profiling-hook!'.
Diffstat (limited to 'guix/store.scm')
-rw-r--r--guix/store.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/guix/store.scm b/guix/store.scm
index f336df85cc..e6e45ba89c 100644
--- a/guix/store.scm
+++ b/guix/store.scm
@@ -25,6 +25,7 @@
#:use-module (guix base16)
#:use-module (guix base32)
#:use-module (guix hash)
+ #:use-module (guix profiling)
#:autoload (guix build syscalls) (terminal-columns)
#:use-module (rnrs bytevectors)
#:use-module (ice-9 binary-ports)
@@ -794,16 +795,14 @@ bytevector) as its internal buffer, and a thunk to flush this output port."
(define record-operation
;; Optionally, increment the number of calls of the given RPC.
- (let ((profiled (or (and=> (getenv "GUIX_PROFILING") string-tokenize)
- '())))
- (if (member "rpc" profiled)
- (begin
- (add-hook! exit-hook show-rpc-profile)
- (lambda (name)
- (let ((count (or (hashq-ref %rpc-calls name) 0)))
- (hashq-set! %rpc-calls name (+ count 1)))))
- (lambda (_)
- #t))))
+ (if (profiled? "rpc")
+ (begin
+ (register-profiling-hook! "rpc" show-rpc-profile)
+ (lambda (name)
+ (let ((count (or (hashq-ref %rpc-calls name) 0)))
+ (hashq-set! %rpc-calls name (+ count 1)))))
+ (lambda (_)
+ #t)))
(define-syntax operation
(syntax-rules ()