summaryrefslogtreecommitdiff
path: root/guix/profiles.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-03 20:12:59 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-04 00:10:03 +0200
commitafd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6 (patch)
treee53fe41f65e71aae9257aa37d8e1fd9ad6706439 /guix/profiles.scm
parent8a55e217ad3a6af96f9e05eb676616224fde509f (diff)
downloadgnu-guix-afd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6.tar
gnu-guix-afd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6.tar.gz
Use "normalized codesets" everywhere.
In other words, change "xx_YY.UTF-8" to "xx_YY.utf8". * guix/profiles.scm (ca-certificate-bundle): Use "en_US.utf8" instead of "en_US.UTF-8". * guix/packages.scm (patch-and-repack): Likewise. * guix/build/gnu-build-system.scm (install-locale): Likewise. * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Likewise. * gnu/packages/python.scm (python-ipython): Likewise. * gnu/packages/gawk.scm (gawk): Likewise. * build-aux/hydra/demo-os.scm: Likewise. * gnu/packages/guile.scm (guile-ncurses)[arguments]: Remove 'change-locale' phase.
Diffstat (limited to 'guix/profiles.scm')
-rw-r--r--guix/profiles.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/profiles.scm b/guix/profiles.scm
index c56ebb145b..fac322bbab 100644
--- a/guix/profiles.scm
+++ b/guix/profiles.scm
@@ -576,7 +576,7 @@ MANIFEST. Single-file bundles are required by programs such as Git and Lynx."
(setenv "LOCPATH"
(string-append #+glibc-utf8-locales "/lib/locale/"
#+(package-version glibc-utf8-locales)))
- (setlocale LC_ALL "en_US.UTF-8")
+ (setlocale LC_ALL "en_US.utf8")
(match (append-map ca-files '#$(manifest-inputs manifest))
(()