summaryrefslogtreecommitdiff
path: root/guix/packages.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-05-04 22:11:37 +0200
committerLudovic Courtès <ludo@gnu.org>2015-05-04 23:30:51 +0200
commite89431bf016830a919ec2430889f6c2679aab408 (patch)
tree70c2e186a551fd1b2654d99275c4bb558a38f9ee /guix/packages.scm
parent934d37069436b3f8e65478f0a5329ef0d72fdb15 (diff)
downloadgnu-guix-e89431bf016830a919ec2430889f6c2679aab408.tar
gnu-guix-e89431bf016830a919ec2430889f6c2679aab408.tar.gz
Move search path specifications to (guix search-paths).
* guix/packages.scm (<search-path-specification>, search-path-specification->sexp, sexp->search-path-specification): Move to... * guix/search-paths.scm: ... here. New file. * Makefile.am (MODULES): Add it. * guix/build-system/cmake.scm, guix/build-system/glib-or-gtk.scm, guix/build-system/gnu.scm, guix/build-system/haskell.scm, guix/build-system/perl.scm, guix/build-system/python.scm, guix/build-system/ruby.scm, guix/build-system/waf.scm, guix/profiles.scm, guix/scripts/package.scm: Use it.
Diffstat (limited to 'guix/packages.scm')
-rw-r--r--guix/packages.scm44
1 files changed, 3 insertions, 41 deletions
diff --git a/guix/packages.scm b/guix/packages.scm
index d7fced8384..c955b35155 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -26,6 +26,7 @@
#:use-module (guix base32)
#:use-module (guix derivations)
#:use-module (guix build-system)
+ #:use-module (guix search-paths)
#:use-module (guix gexp)
#:use-module (ice-9 match)
#:use-module (ice-9 vlist)
@@ -36,7 +37,8 @@
#:use-module (srfi srfi-34)
#:use-module (srfi srfi-35)
#:re-export (%current-system
- %current-target-system)
+ %current-target-system
+ search-path-specification) ;for convenience
#:export (origin
origin?
origin-uri
@@ -52,12 +54,6 @@
origin-imported-modules
base32
- <search-path-specification>
- search-path-specification
- search-path-specification?
- search-path-specification->sexp
- sexp->search-path-specification
-
package
package?
package-name
@@ -189,40 +185,6 @@ representation."
((_ str)
#'(nix-base32-string->bytevector str)))))
-;; The specification of a search path.
-(define-record-type* <search-path-specification>
- search-path-specification make-search-path-specification
- search-path-specification?
- (variable search-path-specification-variable) ;string
- (files search-path-specification-files) ;list of strings
- (separator search-path-specification-separator ;string
- (default ":"))
- (file-type search-path-specification-file-type ;symbol
- (default 'directory))
- (file-pattern search-path-specification-file-pattern ;#f | string
- (default #f)))
-
-(define (search-path-specification->sexp spec)
- "Return an sexp representing SPEC, a <search-path-specification>. The sexp
-corresponds to the arguments expected by `set-path-environment-variable'."
- ;; Note that this sexp format is used both by build systems and in
- ;; (guix profiles), so think twice before you change it.
- (match spec
- (($ <search-path-specification> variable files separator type pattern)
- `(,variable ,files ,separator ,type ,pattern))))
-
-(define (sexp->search-path-specification sexp)
- "Convert SEXP, which is as returned by 'search-path-specification->sexp', to
-a <search-path-specification> object."
- (match sexp
- ((variable files separator type pattern)
- (search-path-specification
- (variable variable)
- (files files)
- (separator separator)
- (file-type type)
- (file-pattern pattern)))))
-
(define %supported-systems
;; This is the list of system types that are supported. By default, we
;; expect all packages to build successfully here.