summaryrefslogtreecommitdiff
path: root/guix/licenses.scm
diff options
context:
space:
mode:
authorPetter <petter@mykolab.ch>2017-05-02 16:57:52 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-02 23:41:14 +0200
commit2f3108ad036d5d59d0c8247703ba22adb57638e5 (patch)
tree185532b3425ea6e04f51d99ef8964e6ce07801ce /guix/licenses.scm
parentdcb95c1fc936d74dfdf84b7e59eff66cb99c5a63 (diff)
downloadgnu-guix-2f3108ad036d5d59d0c8247703ba22adb57638e5.tar
gnu-guix-2f3108ad036d5d59d0c8247703ba22adb57638e5.tar.gz
gnu: Avoid circular dependencies by Perl license.
* guix/licenses.scm (perl-license): New variable. * gnu/packages/bioinformatics.scm: Change (package-license perl) to perl-license. * gnu/packages/compression.scm: Same. * gnu/packages/databases.scm: Same. * gnu/packages/gd.scm: Same. * gnu/packages/language.scm: Same. * gnu/packages/libevent.scm: Same. * gnu/packages/mail.scm: Same. * gnu/packages/messaging.scm: Same. * gnu/packages/ncurses.scm: Same. * gnu/packages/networking.scm: Same. * gnu/packages/photo.scm: Same. * gnu/packages/tcl.scm: Same. * gnu/packages/tex.scm: Same. * gnu/packages/tls.scm: Same. * gnu/packages/web.scm: Same. * gnu/packages/wm.scm: Same. * gnu/packages/xml.scm: Same. * gnu/packages/xorg.scm: Same. * gnu/packages/zip.scm: Same. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/licenses.scm')
-rw-r--r--guix/licenses.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/guix/licenses.scm b/guix/licenses.scm
index c6945288fe..a95f89a7bf 100644
--- a/guix/licenses.scm
+++ b/guix/licenses.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016, 2017 ng0 <ng0@libertad.pw>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,6 +63,7 @@
ncsa
nmap
openldap2.8 openssl
+ perl-license
psfl public-domain
qpl
repoze
@@ -407,6 +409,12 @@ at URI, which may be a file:// URI pointing the package's tree."
"https://www.gnu.org/licenses/license-list#newOpenLDAP"))
;; lists OpenLDAPv2.7, which is virtually identical
+(define perl-license
+ ;; The license of Perl, GPLv1+ or Artistic (we ignore the latter here).
+ ;; We define this alias to avoid circular dependencies introduced by the use
+ ;; of the '(package-license perl)' idiom.
+ gpl1+)
+
(define psfl
(license "Python Software Foundation License"
"http://docs.python.org/license.html"