summaryrefslogtreecommitdiff
path: root/guix/import/gem.scm
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-09-01 19:57:44 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-09-01 20:00:01 -0400
commita96524cc7d302ad6a8f2cd2e970a148b360f629a (patch)
tree5bc3f8b199a48229692ff8381d7a3a80c3ee571d /guix/import/gem.scm
parent385a44bebb4a33517165efa2f75ab376c2263db6 (diff)
downloadgnu-guix-a96524cc7d302ad6a8f2cd2e970a148b360f629a.tar
gnu-guix-a96524cc7d302ad6a8f2cd2e970a148b360f629a.tar.gz
import: gem: Fix minor bug and add unit test.
* guix/import/gem.scm (make-gem-sexp): Properly handle an empty list of licenses. When rendering a list of licenses, cons 'list onto the front of the expression. * tests/gem.scm: New file. * Makefile.am (SCM_TESTS): Add it.
Diffstat (limited to 'guix/import/gem.scm')
-rw-r--r--guix/import/gem.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/guix/import/gem.scm b/guix/import/gem.scm
index 3c28d1d9fd..c64c4e9374 100644
--- a/guix/import/gem.scm
+++ b/guix/import/gem.scm
@@ -105,8 +105,9 @@ VERSION, HASH, HOME-PAGE, DESCRIPTION, DEPENDENCIES, and LICENSES."
(description ,description)
(home-page ,home-page)
(license ,(match licenses
+ (() #f)
((license) (license->symbol license))
- (_ (map license->symbol licenses))))))
+ (_ `(list ,@(map license->symbol licenses)))))))
(define* (gem->guix-package package-name #:optional version)
"Fetch the metadata for PACKAGE-NAME from rubygems.org, and return the