summaryrefslogtreecommitdiff
path: root/guix/http-client.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-17 23:07:01 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-18 00:39:49 +0100
commit36626c556ed75219bce196ac93d148f6b9af984c (patch)
tree518c887e6bf45c647e3793534f4ab87b77ddfad8 /guix/http-client.scm
parent5461115e8fd9a3181506307b6090716a0d5c202c (diff)
downloadgnu-guix-36626c556ed75219bce196ac93d148f6b9af984c.tar
gnu-guix-36626c556ed75219bce196ac93d148f6b9af984c.tar.gz
build: Require Guile >= 2.0.9.
* configure.ac: Bump requirement to 2.0.9. * doc/guix.texi (Requirements): Adjust accordingly. * README (Requirements): Likewise. * build-aux/download.scm: Remove workaround for <http://bugs.gnu.org/13095>. * guix/build/download.scm: Likewise. (http-fetch)[post-2.0.7?]: Remove. Remove conditional code for not POST-2.0.7?. * guix/http-client.scm: Remove workaround for <http://bugs.gnu.org/13095>. (http-fetch)[post-2.0.7?]: Remove. Remove conditional code for not POST-2.0.7?. * guix/serialization.scm (read-latin1-string): Remove mention of 2.0.9. * tests/nar.scm: Use (ice-9 control). (let/ec): Remove.
Diffstat (limited to 'guix/http-client.scm')
-rw-r--r--guix/http-client.scm15
1 files changed, 3 insertions, 12 deletions
diff --git a/guix/http-client.scm b/guix/http-client.scm
index 78d39a0208..855ae95a43 100644
--- a/guix/http-client.scm
+++ b/guix/http-client.scm
@@ -217,10 +217,6 @@ or if EOF is reached."
(when (module-variable %web-http 'read-line*)
(module-set! %web-http 'read-line* read-header-line))))
-;; XXX: Work around <http://bugs.gnu.org/13095>, present in Guile
-;; up to 2.0.7.
-(module-define! (resolve-module '(web client))
- 'shutdown (const #f))
(define* (http-fetch uri #:key port (text? #f) (buffered? #t)
keep-alive? (verify-certificate? #t)
@@ -252,14 +248,9 @@ Raise an '&http-get-error' condition if downloading fails."
(unless (or buffered? (not (file-port? port)))
(setvbuf port _IONBF))
(let*-values (((resp data)
- ;; Try hard to use the API du jour to get an input port.
- (if (guile-version>? "2.0.7")
- (http-get uri #:streaming? #t #:port port
- #:keep-alive? #t
- #:headers headers) ; 2.0.9+
- (http-get* uri #:decode-body? text? ; 2.0.7
- #:keep-alive? #t
- #:port port #:headers headers)))
+ (http-get uri #:streaming? #t #:port port
+ #:keep-alive? #t
+ #:headers headers))
((code)
(response-code resp)))
(case code