summaryrefslogtreecommitdiff
path: root/guix/gnu-maintenance.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-11 15:30:58 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-11 15:31:35 +0100
commit7047133f0777789107bd9f61f62c7d6ca10ed164 (patch)
tree3d7cfbdd51d0dc54cd83cb9aa58c0692b4274bc4 /guix/gnu-maintenance.scm
parent501d76475185127388c7776f89fb6526db4f1336 (diff)
downloadgnu-guix-7047133f0777789107bd9f61f62c7d6ca10ed164.tar
gnu-guix-7047133f0777789107bd9f61f62c7d6ca10ed164.tar.gz
import: Add GNU importer.
Suggested by Karl Berry <karl@gnu.org> and Andreas Enge <andreas@enge.fr>. * guix/import/gnu.scm, guix/scripts/import/gnu.scm: New files. * Makefile.am (MODULES): Add them. * guix/scripts/import.scm (importers): Add "gnu". * guix/gnu-maintenance.scm (gnu-release-archive-types): New procedure. (download-tarball): Export.
Diffstat (limited to 'guix/gnu-maintenance.scm')
-rw-r--r--guix/gnu-maintenance.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/guix/gnu-maintenance.scm b/guix/gnu-maintenance.scm
index bfc03359ac..ee84446549 100644
--- a/guix/gnu-maintenance.scm
+++ b/guix/gnu-maintenance.scm
@@ -64,7 +64,10 @@
releases
latest-release
+ gnu-release-archive-types
gnu-package-name->name+version
+
+ download-tarball
package-update-path
package-update
update-package-source))
@@ -382,6 +385,11 @@ open (resp. close) FTP connections; this can be useful to reuse connections."
(ftp-close conn)
#f)))))))))
+(define (gnu-release-archive-types release)
+ "Return the available types of archives for RELEASE---a list of strings such
+as \"gz\" or \"xz\"."
+ (map file-extension (gnu-release-files release)))
+
(define %package-name-rx
;; Regexp for a package name, e.g., "foo-X.Y". Since TeXmacs uses
;; "TeXmacs-X.Y-src", the `-src' suffix is allowed.