summaryrefslogtreecommitdiff
path: root/guix/download.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-07 23:42:13 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-07 23:58:08 +0100
commit6c5b56f9fa01b7fe9034bac47b20e08a2fdb2629 (patch)
tree2a885e2bdfe4db48e6fd41efc8c5250f4bfa966f /guix/download.scm
parentfaa65e2735d62254edb7cc897f91feae80e7c8d2 (diff)
downloadgnu-guix-6c5b56f9fa01b7fe9034bac47b20e08a2fdb2629.tar
gnu-guix-6c5b56f9fa01b7fe9034bac47b20e08a2fdb2629.tar.gz
gnu: bash: Use the bootstrap Guile in 'url-fetch/reset-patch-level'.
Fixes <http://bugs.gnu.org/25775>. Reported by Sirgazil, Ricardo Wurmus, Andy Wingo, and others. * guix/download.scm (in-band-download): Always use GUILE. This reverts 9f05908fb1e3707cae593d94688748294717a546. * gnu/packages/bash.scm (url-fetch/reset-patch-level): Remove #:guile. Pass %BOOTSTRAP-GUILE as #:guile to 'url-fetch'. Remove #:guile-for-build argument in 'gexp->derivation' call.
Diffstat (limited to 'guix/download.scm')
-rw-r--r--guix/download.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/guix/download.scm b/guix/download.scm
index 86f8598812..813f51f489 100644
--- a/guix/download.scm
+++ b/guix/download.scm
@@ -418,10 +418,7 @@ GnuTLS itself and its dependencies. See <http://bugs.gnu.org/22774>."
;; hash of the expected result.
#:verify-certificate? #f)))))
- (mlet %store-monad ((guile (package->derivation
- (or guile
- (@@ (gnu packages bootstrap) %bootstrap-guile))
- system)))
+ (mlet %store-monad ((guile (package->derivation guile system)))
(gexp->derivation file-name builder
#:guile-for-build guile
#:system system