summaryrefslogtreecommitdiff
path: root/guix/config.scm.in
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-08 11:03:31 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-14 11:17:00 +0200
commitea0a06cee2ba05451f94714a4f913db02efbe92c (patch)
tree8447b4531818371310470446a17f77d313bb991a /guix/config.scm.in
parentdf2f6400b1fbc282ef4d6dd7124ea1c17adc23c2 (diff)
downloadgnu-guix-ea0a06cee2ba05451f94714a4f913db02efbe92c.tar
gnu-guix-ea0a06cee2ba05451f94714a4f913db02efbe92c.tar.gz
Remove 'guix-register' and its traces.
* Makefile.am (SH_TESTS): Remove tests/guix-register.sh. * build-aux/pre-inst-env.in (GUIX_REGISTER): Remove. * gnu/build/install.scm (directives): Remove outdated comment. * gnu/build/vm.scm (root-partition-initializer): Update comment. * gnu/packages/package-management.scm (guix-register): Remove. * guix/config.scm.in (%sbindir, %guix-register-program): Remove. * guix/scripts/system.scm (install): Adjust docstring. * guix/self.scm (make-config.scm): Remove #:guix. Do not generate %sbindir and %guix-register-program. (specification->package): Remove "guix". * nix/guix-register/guix-register.cc: Remove. * nix/libstore/store-api.cc (decodeValidPathInfo): Remove. * nix/libstore/store-api.hh (decodeValidPathInfo): Remove declaration. * nix/local.mk (sbin_PROGRAMS, guix_register_SOURCES) (guix_register_CPPFLAGS, guix_register_LDFLAGS): Remove. * tests/guix-register.sh: Remove.
Diffstat (limited to 'guix/config.scm.in')
-rw-r--r--guix/config.scm.in12
1 files changed, 1 insertions, 11 deletions
diff --git a/guix/config.scm.in b/guix/config.scm.in
index aeea81bd3f..4490112e07 100644
--- a/guix/config.scm.in
+++ b/guix/config.scm.in
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Caleb Ristvedt <caleb.ristvedt@cune.org>
;;;
;;; This file is part of GNU Guix.
@@ -26,13 +26,11 @@
%storedir
%localstatedir
%sysconfdir
- %sbindir
%store-directory
%state-directory
%store-database-directory
%config-directory
- %guix-register-program
%system
%libgcrypt
@@ -70,9 +68,6 @@
(define %sysconfdir
"@guix_sysconfdir@")
-(define %sbindir
- "@guix_sbindir@")
-
(define %store-directory
(or (and=> (getenv "NIX_STORE_DIR") canonicalize-path)
%storedir))
@@ -91,11 +86,6 @@
(or (getenv "GUIX_CONFIGURATION_DIRECTORY")
(string-append %sysconfdir "/guix")))
-(define %guix-register-program
- ;; The 'guix-register' program.
- (or (getenv "GUIX_REGISTER")
- (string-append %sbindir "/guix-register")))
-
(define %system
"@guix_system@")