summaryrefslogtreecommitdiff
path: root/guix/config.scm.in
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-23 19:44:38 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-26 23:11:07 +0200
commit9dd674db017dbdc451cfd35da2dc3ce08db0726a (patch)
treefdab5b2f68ea609b90c80606466ad7702f3f8dbc /guix/config.scm.in
parent8ac6282c4b97ece43b922a8c1a99a0a8e753c765 (diff)
downloadgnu-guix-9dd674db017dbdc451cfd35da2dc3ce08db0726a.tar
gnu-guix-9dd674db017dbdc451cfd35da2dc3ce08db0726a.tar.gz
daemon: Rename 'NIX_CONF_DIR' to 'GUIX_CONFIGURATION_DIRECTORY'.
Partly fixes <http://bugs.gnu.org/22459>. Reported by Jeff Mickey <j@codemac.net> and David Craven <david@craven.ch>. * nix/libstore/globals.cc (Settings::processEnvironment()): Change 'NIX_CONF_DIR' to 'GUIX_CONFIGURATION_DIRECTORY'. * nix/local.mk (libstore_a_CPPFLAGS): Likewise. * guix/config.scm.in (%config-directory): Likewise. * build-aux/test-env.in: Likewise. * gnu/packages/patches/hydra-automake-1.15.patch: Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix/config.scm.in')
-rw-r--r--guix/config.scm.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/config.scm.in b/guix/config.scm.in
index d7df9f7d2b..adffa0cfec 100644
--- a/guix/config.scm.in
+++ b/guix/config.scm.in
@@ -59,8 +59,8 @@
(or (getenv "NIX_STATE_DIR") "@guix_localstatedir@/guix"))
(define %config-directory
- ;; This must match `NIX_CONF_DIR' as defined in `nix/local.mk'.
- (or (getenv "NIX_CONF_DIR") "@guix_sysconfdir@/guix"))
+ ;; This must match `GUIX_CONFIGURATION_DIRECTORY' as defined in `nix/local.mk'.
+ (or (getenv "GUIX_CONFIGURATION_DIRECTORY") "@guix_sysconfdir@/guix"))
(define %guix-register-program
;; The 'guix-register' program.