summaryrefslogtreecommitdiff
path: root/guix/build
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-12-18 21:43:53 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-18 22:16:23 +0100
commit6e8986c8388e889eb74509999aea826fd440dcc4 (patch)
treefff8eafadede4056fa3efaebd2eeedc854c4fe84 /guix/build
parentd852cf9e331888c23b4f9377064145ae74339644 (diff)
downloadgnu-guix-6e8986c8388e889eb74509999aea826fd440dcc4.tar
gnu-guix-6e8986c8388e889eb74509999aea826fd440dcc4.tar.gz
build: Add dune-build-system.
* guix/build/dune-build-system.scm, guix/build-system/dune.scm: New files. * Makefile.am (MODULES): Add them. * doc/guix.texi (Build Systems): Document dune-build-system. * guix/build-system/ocaml.scm (lower, default-findlib, default-ocaml): Export them. (package-with-explicit-ocaml): Also transform packages built with dune-build-system.
Diffstat (limited to 'guix/build')
-rw-r--r--guix/build/dune-build-system.scm69
1 files changed, 69 insertions, 0 deletions
diff --git a/guix/build/dune-build-system.scm b/guix/build/dune-build-system.scm
new file mode 100644
index 0000000000..fcc2d6567d
--- /dev/null
+++ b/guix/build/dune-build-system.scm
@@ -0,0 +1,69 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build dune-build-system)
+ #:use-module ((guix build ocaml-build-system) #:prefix ocaml:)
+ #:use-module (guix build utils)
+ #:use-module (ice-9 match)
+ #:export (%standard-phases
+ dune-build))
+
+;; Commentary:
+;;
+;; Builder-side code of the standard dune build procedure.
+;;
+;; Code:
+
+(define* (build #:key (build-flags '()) (jbuild? #f)
+ (use-make? #f) #:allow-other-keys)
+ "Build the given package."
+ (let ((program (if jbuild? "jbuilder" "dune")))
+ (apply invoke program "build" "@install" build-flags))
+ #t)
+
+(define* (check #:key (test-flags '()) (test-target "test") tests?
+ (jbuild? #f) #:allow-other-keys)
+ "Test the given package."
+ (when tests?
+ (let ((program (if jbuild? "jbuilder" "dune")))
+ (apply invoke program "runtest" test-target test-flags)))
+ #t)
+
+(define* (install #:key outputs (install-target "install") (jbuild? #f)
+ #:allow-other-keys)
+ "Install the given package."
+ (let ((out (assoc-ref outputs "out"))
+ (program (if jbuild? "jbuilder" "dune")))
+ (invoke program install-target "--prefix" out))
+ #t)
+
+(define %standard-phases
+ ;; Everything is as with the GNU Build System except for the `configure'
+ ;; , `build', `check' and `install' phases.
+ (modify-phases ocaml:%standard-phases
+ (delete 'configure)
+ (replace 'build build)
+ (replace 'check check)
+ (replace 'install install)))
+
+(define* (dune-build #:key inputs (phases %standard-phases)
+ #:allow-other-keys #:rest args)
+ "Build the given package, applying all of PHASES in order."
+ (apply ocaml:ocaml-build #:inputs inputs #:phases phases args))
+
+;;; dune-build-system.scm ends here