summaryrefslogtreecommitdiff
path: root/guix/build-system
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-09-10 15:42:07 -0400
committerLeo Famulari <leo@famulari.name>2018-09-10 15:44:32 -0400
commit875d0681768408997cda108457aaf10116da3732 (patch)
treeda3bb1410e6262015c97dfb31e897760c45f3616 /guix/build-system
parentc5e4b4cc8f424a453f064b7c8e5d434e72885392 (diff)
downloadgnu-guix-875d0681768408997cda108457aaf10116da3732.tar
gnu-guix-875d0681768408997cda108457aaf10116da3732.tar.gz
Adjust all users of (gnu packages ldc) to use (gnu packages dlang).
This is a followup to commit 98d6543f86d01486c2f6e808eedd97c601ba3e7a. * gnu/packages/bioinformatics.scm, guix/build-system/dub.scm: Adjust accordingly.
Diffstat (limited to 'guix/build-system')
-rw-r--r--guix/build-system/dub.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/build-system/dub.scm b/guix/build-system/dub.scm
index 13c89e8648..5a31a2f51a 100644
--- a/guix/build-system/dub.scm
+++ b/guix/build-system/dub.scm
@@ -35,13 +35,13 @@
(define (default-ldc)
"Return the default ldc package."
;; Lazily resolve the binding to avoid a circular dependency.
- (let ((ldc (resolve-interface '(gnu packages ldc))))
+ (let ((ldc (resolve-interface '(gnu packages dlang))))
(module-ref ldc 'ldc)))
(define (default-dub)
"Return the default dub package."
;; Lazily resolve the binding to avoid a circular dependency.
- (let ((ldc (resolve-interface '(gnu packages ldc))))
+ (let ((ldc (resolve-interface '(gnu packages dlang))))
(module-ref ldc 'dub)))
(define (default-pkg-config)