summaryrefslogtreecommitdiff
path: root/guix/build-system/asdf.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2017-04-03 09:01:26 -0400
committerRicardo Wurmus <rekado@elephly.net>2017-05-16 15:18:15 +0200
commit6de91ba2a14fd5c15721d87b63e7f8ab52a29a67 (patch)
tree49d86a1f5835ee142d890adc4afb7ac876f36625 /guix/build-system/asdf.scm
parent26a16d37ff4ae50f6e5f8eac97fa7c17631f59ae (diff)
downloadgnu-guix-6de91ba2a14fd5c15721d87b63e7f8ab52a29a67.tar
gnu-guix-6de91ba2a14fd5c15721d87b63e7f8ab52a29a67.tar.gz
build-system/asdf: Make #:lisp a package argument.
* guix/build-system/asdf.scm (lower): Change argument name to `lisp-type'. (asdf-build): Change argument name to `lisp-type'. Remove `lisp' as an argument to the returned procedure. Change the argument passed to build phases to `lisp-type'. * guix/build/asdf-build-system.scm (copy-source, build, check) (create-asd-file, symlink-asd-files, cleanup-files, strip): Respect `lisp-type` argument. * gnu/packages/lisp.scm (sbcl-stumpwm, sbcl-stumpwm+slynk): Likewise.
Diffstat (limited to 'guix/build-system/asdf.scm')
-rw-r--r--guix/build-system/asdf.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/guix/build-system/asdf.scm b/guix/build-system/asdf.scm
index d02565b2d1..1ef6f32d4c 100644
--- a/guix/build-system/asdf.scm
+++ b/guix/build-system/asdf.scm
@@ -232,10 +232,10 @@ set up using CL source package conventions."
(properties (alist-delete variant properties)))
pkg))
-(define (lower lisp-implementation)
+(define (lower lisp-type)
(lambda* (name
#:key source inputs outputs native-inputs system target
- (lisp (default-lisp (string->symbol lisp-implementation)))
+ (lisp (default-lisp (string->symbol lisp-type)))
#:allow-other-keys
#:rest arguments)
"Return a bag for NAME"
@@ -251,18 +251,17 @@ set up using CL source package conventions."
'())
,@inputs
,@(standard-packages)))
- (build-inputs `((,lisp-implementation ,lisp)
+ (build-inputs `((,lisp-type ,lisp)
,@native-inputs))
(outputs outputs)
- (build (asdf-build lisp-implementation))
+ (build (asdf-build lisp-type))
(arguments (strip-keyword-arguments private-keywords arguments))))))
-(define (asdf-build lisp-implementation)
+(define (asdf-build lisp-type)
(lambda* (store name inputs
#:key source outputs
(tests? #t)
(asd-file #f)
- (lisp lisp-implementation)
(phases '(@ (guix build asdf-build-system)
%standard-phases))
(search-paths '())
@@ -280,7 +279,7 @@ set up using CL source package conventions."
(derivation->output-path source))
((source) source)
(source source))
- #:lisp ,lisp
+ #:lisp-type ,lisp-type
#:asd-file ,asd-file
#:system ,system
#:tests? ,tests?