summaryrefslogtreecommitdiff
path: root/guix/build-system.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-03 18:06:16 +0200
committerLudovic Courtès <ludo@gnu.org>2014-10-05 21:58:42 +0200
commit0d5a559f0f81e14c695e5aab178b30edf66088f3 (patch)
treefe43647edc18b8a85885436f9a40a6ff4281e19f /guix/build-system.scm
parent2348fd0f51b6eeabde2e384ef495b3a0adbd6bfb (diff)
downloadgnu-guix-0d5a559f0f81e14c695e5aab178b30edf66088f3.tar
gnu-guix-0d5a559f0f81e14c695e5aab178b30edf66088f3.tar.gz
build-system: Introduce "bags" as an intermediate representation.
* guix/build-system.scm (<build-system>)[build, cross-build]: Remove. [lower]: New field. (<bag>): New record type. (make-bag): New procedure. * guix/packages.scm (bag-transitive-inputs, bag-transitive-build-inputs, bag-transitive-host-inputs, bag-transitive-target-inputs, package->bag): New procedures. (package-derivation): Use it; use the bag, apply its build procedure, etc. (package-cross-derivation): Likewise. * gnu/packages/bootstrap.scm (raw-build, make-raw-bag): New procedure. (%bootstrap-guile): Use them. * guix/build-system/trivial.scm (lower): New procedure. (trivial-build, trivial-cross-build): Remove 'source' parameter. Pass INPUTS as is. (trivial-build-system): Adjust accordingly. * guix/build-system/gnu.scm (%store, inputs-search-paths, standard-search-paths, expand-inputs, standard-inputs): Remove. (gnu-lower): New procedure. (gnu-build): Remove 'source' and #:implicit-inputs? parameters. Remove 'implicit-inputs' and 'implicit-search-paths' variables. Get the source from INPUT-DRVS. (gnu-cross-build): Likewise. (standard-cross-packages): Remove call to 'standard-packages'. (standard-cross-inputs, standard-cross-search-paths): Remove. (gnu-build-system): Remove 'build' and 'cross-build'; add 'lower'. * guix/build-system/cmake.scm (lower): New procedure. (cmake-build): Remove 'source' and #:cmake parameters. Use INPUTS and SEARCH-PATHS as is. Get the source from INPUTS. * guix/build-system/perl.scm: Likewise. * guix/build-system/python.scm: Likewise. * guix/build-system/ruby.scm: Likewise. * gnu/packages/cross-base.scm (cross-gcc): Change "cross-linux-headers" to "linux-headers". (cross-libc)[xlinux-headers]: Pass #:implicit-cross-inputs? #f. Likewise. In 'propagated-inputs', change "cross-linux-headers" to "linux-headers". * guix/git-download.scm (git-fetch): Use 'standard-packages' instead of 'standard-inputs'. * tests/builders.scm ("gnu-build-system"): Remove use of 'build-system-builder'. ("gnu-build"): Remove 'source' and #:implicit-inputs? arguments to 'gnu-build'. * tests/packages.scm ("search paths"): Adjust to new build system API. ("package-cross-derivation, no cross builder"): Likewise. * doc/guix.texi (Build Systems): Add paragraph on bags.
Diffstat (limited to 'guix/build-system.scm')
-rw-r--r--guix/build-system.scm68
1 files changed, 62 insertions, 6 deletions
diff --git a/guix/build-system.scm b/guix/build-system.scm
index c618a5e243..f185d5704f 100644
--- a/guix/build-system.scm
+++ b/guix/build-system.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -18,17 +18,73 @@
(define-module (guix build-system)
#:use-module (guix records)
+ #:use-module (ice-9 match)
#:export (build-system
build-system?
build-system-name
build-system-description
- build-system-builder
- build-system-cross-builder))
+ build-system-lower
+
+ bag
+ bag?
+ bag-name
+ bag-build-inputs
+ bag-host-inputs
+ bag-target-inputs
+ bag-outputs
+ bag-arguments
+ bag-build
+
+ make-bag))
(define-record-type* <build-system> build-system make-build-system
build-system?
(name build-system-name) ; symbol
(description build-system-description) ; short description
- (build build-system-builder) ; (store system name source inputs)
- (cross-build build-system-cross-builder ; (store system x-system ...)
- (default #f)))
+ (lower build-system-lower)) ; args ... -> bags
+
+;; "Bags" are low-level representations of "packages". Here we use
+;; build/host/target in the sense of the GNU tool chain (info "(autoconf)
+;; Specifying Target Triplets").
+(define-record-type* <bag> bag %make-bag
+ bag?
+ (name bag-name) ;string
+ (build-inputs bag-build-inputs ;list of packages
+ (default '()))
+ (host-inputs bag-host-inputs ;list of packages
+ (default '()))
+
+ ;; "Target inputs" are packages that are built natively, but that are used
+ ;; by target programs in a cross-compilation environment. Thus, they act
+ ;; like 'inputs' as far as search paths are concerned. The only example of
+ ;; that is the cross-libc: it is an input of 'cross-gcc', thus built
+ ;; natively; yet, we want it to be considered as a target input for the
+ ;; purposes of $CPATH, $LIBRARY_PATH, etc.
+ (target-inputs bag-target-inputs
+ (default '()))
+
+ (outputs bag-outputs ;list of strings
+ (default '("out")))
+ (arguments bag-arguments ;list
+ (default '()))
+ (build bag-build)) ;bag -> derivation
+
+(define* (make-bag build-system name
+ #:key source (inputs '()) (native-inputs '())
+ (outputs '()) (arguments '())
+ target)
+ "Ask BUILD-SYSTEM to return a 'bag' for NAME, with the given SOURCE,
+INPUTS, NATIVE-INPUTS, OUTPUTS, and additional ARGUMENTS. If TARGET is not
+#f, it must be a string with the GNU triplet of a cross-compilation target.
+
+This is the mechanism by which a package is \"lowered\" to a bag, which is the
+intermediate representation just above derivations."
+ (match build-system
+ (($ <build-system> _ description lower)
+ (apply lower name
+ #:source source
+ #:inputs inputs
+ #:native-inputs native-inputs
+ #:outputs outputs
+ #:target target
+ arguments))))