summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-10-07 12:27:37 -0500
committerEric Bavier <bavier@member.fsf.org>2014-10-07 16:37:12 -0500
commitee69f85c7dd055eb20e61f188177f8ccd5c0df7a (patch)
treeea8d05d0b922b9e48f96d8cced4cd82fdd6cfb83 /gnu
parentfa0c1d610444067001faaad204b25fa112fdc838 (diff)
downloadgnu-guix-ee69f85c7dd055eb20e61f188177f8ccd5c0df7a.tar
gnu-guix-ee69f85c7dd055eb20e61f188177f8ccd5c0df7a.tar.gz
gnu: Add potrace.
* gnu/packages/fontutils.scm (potrace): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fontutils.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 5310f3cbe4..321c6dc516 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -197,3 +198,30 @@ process known as shaping. This process takes an input Unicode text string
and returns a sequence of positioned glyphids from the font.")
(license license:lgpl2.1+)
(home-page "http://projects.palaso.org/projects/graphitedev")))
+
+(define-public potrace
+ (package
+ (name "potrace")
+ (version "1.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/potrace/potrace-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1bbyl7jgigawmwc8r14znv8lb6lrcxh8zpvynrl6s800dr4yp9as"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("ghostscript" ,ghostscript))) ;for tests
+ (inputs `(("zlib" ,zlib)))
+ (synopsis "Transform bitmaps into vector graphics")
+ (description
+ "Potrace is a tool for tracing a bitmap, which means, transforming a
+bitmap into a smooth, scalable image. The input is a bitmap (PBM, PGM, PPM,
+or BMP format), and the default output is an encapsulated PostScript
+file (EPS). A typical use is to create EPS files from scanned data, such as
+company or university logos, handwritten notes, etc. The resulting image is
+not \"jaggy\" like a bitmap, but smooth. It can then be rendered at any
+resolution.")
+ (license license:gpl2+)
+ (home-page "http://potrace.sourceforge.net/")))