summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-04-19 20:59:14 +0200
committerLudovic Courtès <ludo@gnu.org>2019-05-06 11:10:21 +0200
commit0209661ee641f94bc151c42aa7963ba56bb425ce (patch)
tree9036c454f5479900c133e72f7b892ad7d40214c6 /gnu
parentdf7d0dce4b2d23853feb111bd6a7dda09c722232 (diff)
downloadgnu-guix-0209661ee641f94bc151c42aa7963ba56bb425ce.tar
gnu-guix-0209661ee641f94bc151c42aa7963ba56bb425ce.tar.gz
gnu: Add emacs-flycheck-flow.
* gnu/packages/emacs-xyz.scm (emacs-flycheck-flow): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 18bc87ed4a..73dfb2aad0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2770,6 +2770,33 @@ the speedbar window.")
boundaries defined by syntax highlighting.")
(license license:gpl3+))))
+(define-public emacs-flycheck-flow
+ (let ((commit "9e8e52cfc98af6a23fd906f9cb5d5d470d8cf82d")
+ (version "1.1")
+ (revision "1"))
+ (package
+ (name "emacs-flycheck-flow")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lbolla/emacs-flycheck-flow")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "14qldlisbmxzammr500gyha2hiv2xgyzfc6mysqii06kbcqn1ik1"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-flycheck" ,emacs-flycheck)))
+ (home-page "https://github.com/lbolla/emacs-flycheck-flow")
+ (synopsis "Flow support for @code{flycheck-mode}")
+ (description
+ "This package allows @code{flycheck-mode} to provide syntax-checking
+for Flow files.")
+ (license license:gpl3+))))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")