summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2017-02-01 19:51:53 +0100
committerDavid Craven <david@craven.ch>2017-02-10 13:39:01 +0100
commitf23052a6385961a65a786d00d74fdf254043aa25 (patch)
tree14b13b57f524b0bf111fb68397af3e2546fd0b35 /gnu
parentfa73a7c1b3d9b56395152a0284e10171b4fefaed (diff)
downloadgnu-guix-f23052a6385961a65a786d00d74fdf254043aa25.tar
gnu-guix-f23052a6385961a65a786d00d74fdf254043aa25.tar.gz
gnu: mutter: Update to HEAD.
* gnu/packages/gnome.scm (mutter): Update to HEAD. [native-inputs]: Add autoconf, automake and libtool. [arguments]: Add autoreconf phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm30
1 files changed, 21 insertions, 9 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 5f14d109ea..c1ebc19c2a 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4244,17 +4244,20 @@ to display dialog boxes from the commandline and shell scripts.")
(license license:lgpl2.0+)))
(define-public mutter
+ ;; Uses the gnome 3.22 branch that only contains bug fixes.
+ (let ((commit "23c315ea7121e9bd108e2837d0b4beeba53c5e18"))
(package
(name "mutter")
- (version "3.22.2")
+ (version (git-version "3.22.2" "1" commit))
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "git://git.gnome.org/mutter")
+ (commit commit)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "18lj80klfnkwh0cb3ab0i1vfvzbp0zjl73x9d7pna4dsdhsmi6ym"))))
+ "1v1f9xyzjr1ihmfwpq9kzlv2lyr9qn63ck8zny699mbp5hsi11mb"))))
;; NOTE: Since version 3.21.x, mutter now bundles and exports forked
;; versions of cogl and clutter. As a result, many of the inputs,
;; propagated-inputs, and configure flags used in cogl and clutter are
@@ -4277,12 +4280,21 @@ to display dialog boxes from the commandline and shell scripts.")
"--enable-cogl-gst"
(string-append "--with-gl-libname="
(assoc-ref %build-inputs "mesa")
- "/lib/libGL.so"))))
+ "/lib/libGL.so"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'autoreconf
+ (lambda _
+ (zero? (system* "autoreconf" "-vfi")))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-compile-schemas, etc.
("gobject-introspection" ,gobject-introspection)
("intltool" ,intltool)
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ;; For git build
+ ("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
(propagated-inputs
`(;; libmutter.pc refers to these:
("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
@@ -4328,7 +4340,7 @@ to display dialog boxes from the commandline and shell scripts.")
desktop via OpenGL. Mutter combines a sophisticated display engine using the
Clutter toolkit with solid window-management logic inherited from the Metacity
window manager.")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public gnome-online-accounts
(package