summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-02-11 19:23:56 +0100
committerLudovic Courtès <ludo@gnu.org>2017-02-11 22:28:37 +0100
commit71e0f217818b38dde743d14d03a6a3c13256924b (patch)
treed8d6b23c31ed98079baf6c4b1a96f34d96e3e49f /gnu
parent26653538c923a1047dddb7a908d3488feb11808f (diff)
downloadgnu-guix-71e0f217818b38dde743d14d03a6a3c13256924b.tar
gnu-guix-71e0f217818b38dde743d14d03a6a3c13256924b.tar.gz
gnu: Use 'license:' prefix in (gnu packages guile).
* gnu/packages/guile.scm: Import (guix licenses) with the 'license:' prefix.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm58
1 files changed, 29 insertions, 29 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 3e8ab007b3..0ceababba3 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -27,7 +27,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages guile)
- #:use-module (guix licenses)
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
#:use-module (gnu packages aspell)
#:use-module (gnu packages bash)
@@ -129,7 +129,7 @@ the Scheme language which can be easily embedded in other applications to
provide a convenient means of extending the functionality of the application
without requiring the source code to be rewritten.")
(home-page "http://www.gnu.org/software/guile/")
- (license lgpl2.0+)))
+ (license license:lgpl2.0+)))
(define-public guile-2.0
(package
@@ -205,7 +205,7 @@ the Scheme language which can be easily embedded in other applications to
provide a convenient means of extending the functionality of the application
without requiring the source code to be rewritten.")
(home-page "http://www.gnu.org/software/guile/")
- (license lgpl3+)))
+ (license license:lgpl3+)))
(define-public guile-2.0/fixed
;; A package of Guile 2.0 that's rarely changed. It is the one used
@@ -375,7 +375,7 @@ provides several tools for web development: database access, templating
frameworks, session management, URL-remapping for RESTful, page caching, and
more.")
(home-page "https://www.gnu.org/software/artanis/")
- (license (list gpl3+ lgpl3+)))) ;dual license
+ (license (list license:gpl3+ license:lgpl3+)))) ;dual license
(define-public guile-reader
(package
@@ -410,7 +410,7 @@ Guile-Reader’s approach is similar to Common Lisp’s “read table”, but
hopefully more powerful and flexible (for instance, one may instantiate as
many readers as needed).")
(home-page "http://www.nongnu.org/guile-reader/")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-ncurses
(package
@@ -451,7 +451,7 @@ many readers as needed).")
(description
"guile-ncurses provides Guile language bindings for the ncurses
library.")
- (license lgpl3+)))
+ (license license:lgpl3+)))
(define-public mcron
(package
@@ -475,7 +475,7 @@ library.")
tasks on a schedule, such as every hour or every Monday. Mcron is written in
Guile, so its configuration can be written in Scheme; the original cron
format is also supported.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public mcron2
;; This is mthl's mcron development branch, not yet merged in mcron.
@@ -564,7 +564,7 @@ format is also supported.")
pure Scheme. The library can be used to read and write iCalendar data.
The library is shipped with documentation in Info format and usage examples.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-lib
(package
@@ -608,7 +608,7 @@ for Guile\".")
;; The whole is under GPLv3+, but some modules are under laxer
;; distribution terms such as LGPL and public domain. See `COPYING' for
;; details.
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-json
(package
@@ -646,7 +646,7 @@ specification. These are the main features:
@item Unicode support for strings.
@item Allows JSON pretty printing.
@end itemize\n")
- (license lgpl3+)))
+ (license license:lgpl3+)))
(define-public guile2.2-json
(package-for-guile-2.2 guile-json))
@@ -732,7 +732,7 @@ This is Ian Price's r6rs packaged version of miniKanren, which deviates
slightly from miniKanren mainline.
See http://minikanren.org/ for more on miniKanren generally.")
- (license expat)))
+ (license license:expat)))
(define-public guile2.2-minikanren
(package-for-guile-2.2 guile-minikanren))
@@ -817,7 +817,7 @@ See http://minikanren.org/ for more on miniKanren generally.")
"Irregex is an s-expression based alternative to your classic
string-based regular expressions. It implements SRFI 115 and is deeply
inspired by the SCSH regular expression system.")
- (license bsd-3)))
+ (license license:bsd-3)))
(define-public guile2.2-irregex
(package-for-guile-2.2 guile-irregex))
@@ -885,7 +885,7 @@ inspired by the SCSH regular expression system.")
(description
"Guile bindings to the GDBM key-value storage system, using
Guile's foreign function interface.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile2.2-gdbm-ffi
(package-for-guile-2.2 guile-gdbm-ffi))
@@ -939,7 +939,7 @@ Guile's foreign function interface.")
(synopsis "Access SQLite databases from Guile")
(description
"This package provides Guile bindings to the SQLite database system.")
- (license gpl3+))))
+ (license license:gpl3+))))
(define-public haunt
(package
@@ -988,7 +988,7 @@ Guile's foreign function interface.")
Scheme. Haunt features a functional build system and an extensible
interface for reading articles in any format.")
(home-page "http://haunt.dthompson.us")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-config
(package
@@ -1015,7 +1015,7 @@ parameter parsing using getopt-long; basic GNU command-line parameter
generation (--help, --usage, --version); automatic output generation for the
above command-line parameters.")
(home-page "https://github.com/a-sassmannshausen/guile-config")
- (license agpl3+)))
+ (license license:agpl3+)))
(define-public guile-redis
(package
@@ -1048,7 +1048,7 @@ above command-line parameters.")
(synopsis "Redis client library for Guile")
(description "Guile-redis provides a Scheme interface to the Redis
key-value cache and store.")
- (license lgpl3+)))
+ (license license:lgpl3+)))
(define-public guile2.2-redis
(package-for-guile-2.2 guile-redis))
@@ -1127,7 +1127,7 @@ key-value cache and store.")
(description "Wisp is a syntax for Guile which provides a Python-like
whitespace-significant language. It may be easier on the eyes for some
users and in some situations.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-sly
(package
@@ -1162,7 +1162,7 @@ users and in some situations.")
features a functional reactive programming interface and live coding
capabilities.")
(home-page "http://dthompson.us/pages/software/sly.html")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public g-wrap
(package
@@ -1200,7 +1200,7 @@ wrappers for C functions. Given a definition of the types and prototypes for
a given C interface, G-Wrap will automatically generate the C code that
provides access to that interface and its types from the Scheme level.")
(home-page "http://www.nongnu.org/g-wrap/index.html")
- (license lgpl2.1+)))
+ (license license:lgpl2.1+)))
(define-public guile-dbi
(package
@@ -1238,7 +1238,7 @@ provides access to that interface and its types from the Scheme level.")
SQL databases. Database programming with guile-dbi is generic in that the same
programming interface is presented regardless of which database system is used.
It currently supports MySQL, Postgres and SQLite3.")
- (license gpl2+)))
+ (license license:gpl2+)))
(define-public guile-dbd-sqlite3
(package
@@ -1265,7 +1265,7 @@ It currently supports MySQL, Postgres and SQLite3.")
(description
"guile-dbi is a library for Guile that provides a convenient interface to
SQL databases. This package implements the interface for SQLite.")
- (license gpl2+)))
+ (license license:gpl2+)))
(define-public guile-xosd
(package
@@ -1294,7 +1294,7 @@ SQL databases. This package implements the interface for SQLite.")
"Guile-XOSD provides Guile bindings for @code{libxosd},
@uref{http://sourceforge.net/projects/libxosd/, the X On Screen Display
library}.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-daemon
(package
@@ -1319,7 +1319,7 @@ library}.")
"Guile-Daemon is a small Guile program that loads your initial
configuration file, and then reads and evaluates Guile expressions that
you send to a FIFO file.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-commonmark
(package
@@ -1355,7 +1355,7 @@ to transform a CommonMark document to SXML. guile-commonmark tries to closely
follow the @uref{http://commonmark.org/, CommonMark spec}, the main difference
is no support for parsing block and inline level HTML.")
(home-page "https://github.com/OrangeShark/guile-commonmark")
- (license lgpl3+)))
+ (license license:lgpl3+)))
(define-public guile2.2-commonmark
(package-for-guile-2.2 guile-commonmark))
@@ -1438,7 +1438,7 @@ of the C programming language, to be used on bytevectors. C's type
system works on raw memory, and Guile works on bytevectors which are
an abstraction over raw memory. It's also more powerful than the C
type system, elevating types to first-class status.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-aspell
(package
@@ -1474,7 +1474,7 @@ type system, elevating types to first-class status.")
(description
"guile-aspell is a Guile Scheme library for comparing a string against a
dictionary and suggesting spelling corrections.")
- (license gpl3+)))
+ (license license:gpl3+)))
(define-public guile-bash
;; This project is currently retired. It was initially announced here:
@@ -1544,7 +1544,7 @@ enable -f ~/.guix-profile/lib/bash/libguile-bash.so scm
@end example
and then run @command{scm example.scm}.")
- (license gpl3+))))
+ (license license:gpl3+))))
(define-public guile-8sync
(package
@@ -1577,6 +1577,6 @@ and then run @command{scm example.scm}.")
library for GNU Guile based on the actor model.
Note that 8sync is only available for Guile 2.2 (guile-next in Guix).")
- (license lgpl3+)))
+ (license license:lgpl3+)))
;;; guile.scm ends here