summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-07 17:12:16 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-19 19:48:51 -0500
commit8ce231287505dde4339258f3c93a5f409d843b76 (patch)
tree97ef183eb4a853486537132cbb8c460805e21ea6 /gnu
parent38e62c81ee548c466bfa4310e6984485d64e2074 (diff)
downloadgnu-guix-8ce231287505dde4339258f3c93a5f409d843b76.tar
gnu-guix-8ce231287505dde4339258f3c93a5f409d843b76.tar.gz
gnu: Add Perl Readonly.
* gnu/packages/perl.scm (perl-readonly): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index b3442052c5..afa2ba50aa 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3891,6 +3891,27 @@ Module::Build project, but has been externalized here for general use.")
"Probe-Perl-" version))
(license (package-license perl))))
+(define-public perl-readonly
+ (package
+ (name "perl-readonly")
+ (version "2.00")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/S/SA/SANKO/"
+ "Readonly-" version ".tar.gz"))
+ (sha256
+ (base32
+ "165zcf9lpijdpkx82za0g9rx8ckjnhipmcivdkyzshl8jmp1bl4v"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Readonly")
+ (synopsis "Create read-only scalars, arrays, hashes")
+ (description "This module provides a facility for creating non-modifiable
+variables in Perl. This is useful for configuration files, headers, etc. It
+can also be useful as a development and debugging tool for catching updates to
+variables that should not be changed.")
+ (license (package-license perl))))
+
(define-public perl-regexp-common
(package
(name "perl-regexp-common")