summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-04-26 16:38:43 -0400
committerDavid Thompson <dthompson2@worcester.edu>2015-04-27 08:35:40 -0400
commit5809ffccc51adce533530a1b1a0d619532e6d741 (patch)
treee6cb339ca060a6b5fb058772e40a2871cd877d0f /gnu
parent7482b3403b47f190229331277d023771ee3afaed (diff)
downloadgnu-guix-5809ffccc51adce533530a1b1a0d619532e6d741.tar
gnu-guix-5809ffccc51adce533530a1b1a0d619532e6d741.tar.gz
gnu: Add sfml.
* gnu/packages/game-development.scm (sfml): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/game-development.scm44
1 files changed, 43 insertions, 1 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 0e6a1d5b89..219176722a 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -25,7 +25,15 @@
#:use-module (guix build-system gnu)
#:use-module (gnu packages)
#:use-module (gnu packages qt)
- #:use-module (gnu packages compression))
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages zip)
+ #:use-module (gnu packages gl)
+ #:use-module (gnu packages linux)
+ #:use-module (gnu packages xorg)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages audio)
+ #:use-module (gnu packages pulseaudio))
(define-public bullet
(package
@@ -85,3 +93,37 @@ clone.")
;; As noted in 'COPYING', part of it is under GPLv2+, while the rest is
;; under BSD-2.
(license license:gpl2+)))
+
+(define-public sfml
+ (package
+ (name "sfml")
+ (version "2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://mirror0.sfml-dev.org/files/SFML-"
+ version "-sources.zip"))
+ (sha256
+ (base32
+ "1xhkvgyfbhqsjdmfbxvk729kdrzh7kdyagxa3bvpzi6z43mh1frd"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f)) ; no tests
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (inputs
+ `(("mesa" ,mesa)
+ ("glew" ,glew)
+ ("libx11" ,libx11)
+ ("libxrandr" ,libxrandr)
+ ("eudev" ,eudev)
+ ("freetype" ,freetype)
+ ("libjpeg" ,libjpeg)
+ ("libsndfile" ,libsndfile)
+ ("openal" ,openal)))
+ (home-page "http://www.sfml-dev.org")
+ (synopsis "Simple and Fast Multimedia Library")
+ (description
+ "SFML provides a simple interface to the various computer components,
+to ease the development of games and multimedia applications. It is composed
+of five modules: system, window, graphics, audio and network.")
+ (license license:zlib)))