summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-29 16:19:52 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-29 16:19:52 +0800
commit27c4f0cc03448b53053fa33035bdfc5b17178a92 (patch)
treefaab38f95e0c04fe10c62cd39b807db2facd8726 /gnu
parent3ec4bba4c9b4098877dbaa2708b8f758afd05f2f (diff)
downloadgnu-guix-27c4f0cc03448b53053fa33035bdfc5b17178a92.tar
gnu-guix-27c4f0cc03448b53053fa33035bdfc5b17178a92.tar.gz
gnu: Remove gstreamer-0.10 and gst-plugins-base-0.10.
* gnu/packages/gstreamer.scm (gstreamer-0.10, gst-plugins-base-0.10): Remove variables. * gnu/packages/patches/gstreamer-0.10-bison3.patch, gnu/packages/patches/gstreamer-0.10-silly-test.patch: Remove files. * gnu-system.am (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gstreamer.scm46
-rw-r--r--gnu/packages/patches/gstreamer-0.10-bison3.patch32
-rw-r--r--gnu/packages/patches/gstreamer-0.10-silly-test.patch14
3 files changed, 0 insertions, 92 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index b882208d76..03aecdfa53 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -124,32 +124,6 @@ simple plugin with a clean, generic interface.
This package provides the core library and elements.")
(license lgpl2.0+)))
-(define-public gstreamer-0.10
- (package (inherit gstreamer)
- (version "0.10.36")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
- version ".tar.xz"))
- (sha256
- (base32
- "1nkid1n2l3rrlmq5qrf5yy06grrkwjh3yxl5g0w58w0pih8allci"))
- (patches
- (list (search-patch "gstreamer-0.10-bison3.patch")
- (search-patch "gstreamer-0.10-silly-test.patch")))))
- (propagated-inputs
- `(("libxml2" ,libxml2)))
- (inputs `(("glib" ,glib)))
- (native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("glib" ,glib "bin")
- ("python" ,python-2)))))
-
-
(define-public gst-plugins-base
(package
(name "gst-plugins-base")
@@ -288,23 +262,3 @@ developers consider to have good quality code and correct functionality.")
"This GStreamer plugin supports a large number of audio and video
compression formats through the use of the libav library.")
(license gpl2+)))
-
-(define-public gst-plugins-base-0.10
- (package (inherit gst-plugins-base)
- (version "0.10.36")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
- version ".tar.xz"))
- (sha256
- (base32
- "0jp6hjlra98cnkal4n6bdmr577q8mcyp3c08s3a02c4hjhw5rr0z"))))
- (inputs
- `(("glib" ,glib)
- ("gstreamer" ,gstreamer-0.10)))
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("glib" ,glib "bin")
- ("python" ,python-2)))))
diff --git a/gnu/packages/patches/gstreamer-0.10-bison3.patch b/gnu/packages/patches/gstreamer-0.10-bison3.patch
deleted file mode 100644
index f6eb90cb02..0000000000
--- a/gnu/packages/patches/gstreamer-0.10-bison3.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-See https://bugzilla.gnome.org/show_bug.cgi?id=706462
-
-Subject: [PATCH] Make grammar.y work with Bison 3
-
-YYLEX_PARAM is no longer supported in Bison 3.
----
- gst/parse/grammar.y | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/gst/parse/grammar.y b/gst/parse/grammar.y
-index 8a9019c..f533389 100644
---- a/gst/parse/grammar.y
-+++ b/gst/parse/grammar.y
-@@ -26,7 +26,6 @@
- */
-
- #define YYERROR_VERBOSE 1
--#define YYLEX_PARAM scanner
-
- #define YYENABLE_NLS 0
-
-@@ -659,6 +658,7 @@ static int yyerror (void *scanner, graph_t *graph, const char *s);
- %right '.'
- %left '!' '='
-
-+%lex-param { void *scanner }
- %parse-param { void *scanner }
- %parse-param { graph_t *graph }
- %pure-parser
---
-1.8.3.4
-
diff --git a/gnu/packages/patches/gstreamer-0.10-silly-test.patch b/gnu/packages/patches/gstreamer-0.10-silly-test.patch
deleted file mode 100644
index 678dd7b122..0000000000
--- a/gnu/packages/patches/gstreamer-0.10-silly-test.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-See http://lists.freedesktop.org/archives/gstreamer-bugs/2013-January/098461.html
-
-diff -ru gstreamer-0.10.36.orig/tests/check/Makefile.in gstreamer-0.10.36/tests/check/Makefile.in
---- gstreamer-0.10.36.orig/tests/check/Makefile.in 2012-02-20 23:48:29.000000000 +0100
-+++ gstreamer-0.10.36/tests/check/Makefile.in 2013-10-30 21:55:48.000000000 +0100
-@@ -42,7 +42,7 @@
- gst/gstbus$(EXEEXT) gst/gstcaps$(EXEEXT) $(am__EXEEXT_2) \
- gst/gstdatetime$(EXEEXT) gst/gstinfo$(EXEEXT) \
- gst/gstiterator$(EXEEXT) gst/gstmessage$(EXEEXT) \
-- gst/gstminiobject$(EXEEXT) gst/gstobject$(EXEEXT) \
-+ gst/gstminiobject$(EXEEXT) \
- gst/gstpad$(EXEEXT) gst/gstparamspecs$(EXEEXT) \
- gst/gstpoll$(EXEEXT) gst/gstsegment$(EXEEXT) \
- gst/gstsystemclock$(EXEEXT) gst/gstclock$(EXEEXT) \