summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 22:04:51 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:37 -0500
commitf404b5ea6e52ed14640d42e84858fc16a9b42091 (patch)
tree5c3df220efc5a2216f4f98c3058684d93b6cd5ec /gnu
parent2ad520866f44e8c441810dbcce7f60923ee1e37b (diff)
downloadgnu-guix-f404b5ea6e52ed14640d42e84858fc16a9b42091.tar
gnu-guix-f404b5ea6e52ed14640d42e84858fc16a9b42091.tar.gz
gnu: Add python-zope-location.
* gnu/packages/python.scm (python-zope-location, python2-zope-location): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index afba511c6c..9ba4388e7c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6253,3 +6253,28 @@ brokering, etc.) for which the proxy is responsible.")
(define-public python2-zope-proxy
(package-with-python2 python-zope-proxy))
+
+(define-public python-zope-location
+ (package
+ (name "python-zope-location")
+ (version "4.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/z"
+ "/zope.location/zope.location-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nj9da4ksiyv3h8n2vpzwd0pb03mdsh7zy87hfpx72b6p2zcwg74"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-zope-proxy" ,python-zope-proxy)
+ ("python-zope-schema" ,python-zope-schema)))
+ (home-page "http://pypi.python.org/pypi/zope.location/")
+ (synopsis "Zope location library")
+ (description "Zope.location implements the concept of \"locations\" in
+Zope3, which are are special objects that have a structural location.")
+ (license zpl2.1)))
+
+(define-public python2-zope-location
+ (package-with-python2 python-zope-location))