summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-01-17 00:38:26 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-01 11:54:25 +0100
commite896c227e3ce536ae264361c40aa88d83d092776 (patch)
tree37b6f786e4b89cb9b8d592e49c48c26f2671a0dd /gnu
parentb658e165f3b0496ef1d0c260ba4978d7398db5d1 (diff)
downloadgnu-guix-e896c227e3ce536ae264361c40aa88d83d092776.tar
gnu-guix-e896c227e3ce536ae264361c40aa88d83d092776.tar.gz
gnu: libvpx: Move hard-coded logic out of configure phase.
* gnu/packages/video.scm (libvpx)[arguments]: Move arguments from CONFIGURE-PHASE to #:make-flags and #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/video.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 24c8701493..0f419e3571 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1126,20 +1127,19 @@ access to mpv's powerful playback capabilities.")
(patches (search-patches "libvpx-CVE-2016-2818.patch"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "CONFIG_SHELL" (which "bash"))
- (let ((out (assoc-ref outputs "out")))
- (setenv "LDFLAGS"
- (string-append "-Wl,-rpath=" out "/lib"))
- (zero? (system* "./configure"
- "--enable-shared"
+ `(#:configure-flags (list "--enable-shared"
"--as=yasm"
;; Limit size to avoid CVE-2015-1258
"--size-limit=16384x16384"
- (string-append "--prefix=" out)))))))
+ (string-append "--prefix=" (assoc-ref %outputs "out")))
+ #:make-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib"))
+ #:phases (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key configure-flags #:allow-other-keys)
+ ;; The configure script does not understand some of the GNU
+ ;; options, so we only add the flags specified above.
+ (apply invoke "./configure" configure-flags))))
#:tests? #f)) ; no check target
(native-inputs
`(("perl" ,perl)