summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-19 21:29:51 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-21 18:03:06 +0200
commite381ae317c054a8ac52037c3f0df72ca3c96b91f (patch)
tree4b37879f89508cc8e1da7e37980c011de053d6da /gnu
parentecc604baf0357fa32e5e0c983193573eab3cd9d3 (diff)
downloadgnu-guix-e381ae317c054a8ac52037c3f0df72ca3c96b91f.tar
gnu-guix-e381ae317c054a8ac52037c3f0df72ca3c96b91f.tar.gz
gnu: python2-bz2file: Inherit arguments from python-bzfile.
* gnu/packages/python.scm (python-bz2file)[properties]: Remove field. (python2-bz2file): Use PACKAGE-WITH-PYTHON2.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 2 insertions, 15 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 63cf440014..c2987207f4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -8806,23 +8806,10 @@ LDFLAGS and parse the output to build extensions with setup.py.")
files. It contains a drop-in replacement for the I/O interface in the
standard library's @code{bz2} module, including features from the latest
development version of CPython that are not available in older releases.")
- (license license:asl2.0)
- (properties `((python2-variant . ,(delay python2-bz2file))))))
+ (license license:asl2.0)))
(define-public python2-bz2file
- (let ((base (package-with-python2
- (strip-python2-variant python-bz2file))))
- (package
- (inherit base)
- (arguments
- `(#:python ,python-2
- #:phases
- (modify-phases %standard-phases
- ;; 'python setup.py test' does not work as of 0.98.
- ;; There is only the one test file, so we run it directly.
- (replace 'check
- (lambda _ (zero? (system* "python"
- "test_bz2file.py"))))))))))
+ (package-with-python2 python-bz2file))
(define-public python-future
(package