summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-05-23 14:08:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2015-05-24 12:00:17 +0200
commitdf90c701b391087cff47d2277cf89fedb4ee5893 (patch)
tree5190d71dbc26449a445d1a473df2889f8a55e0b5 /gnu
parente99a3d6fd254e2ba5f1864f7679e35cb6a9054f3 (diff)
downloadgnu-guix-df90c701b391087cff47d2277cf89fedb4ee5893.tar
gnu-guix-df90c701b391087cff47d2277cf89fedb4ee5893.tar.gz
gnu: Add seahorse.
* gnu/packages/gnome.scm (seahorse): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6e5e7bbca7..9779452087 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1510,6 +1510,38 @@ engineering.")
"The default GNOME 3 themes (Adwaita and some accessibility themes).")
(license license:lgpl2.1+)))
+(define-public seahorse
+ (package
+ (name "seahorse")
+ (version "3.16.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/" name "-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "0cg1grgpwbfkiny5148n17rzpc8kswyr5yff0kpm8l3lp01my2kp"))))
+ (build-system glib-or-gtk-build-system)
+ (inputs
+ `(("gtk+" ,gtk+)
+ ("gcr" ,gcr)
+ ("gnupg" ,gnupg-1)
+ ("gpgme" ,gpgme)
+ ("libsecret" ,libsecret)))
+ (native-inputs
+ `(("intltool" ,intltool)
+ ("glib:bin" ,glib "bin")
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://launchpad.net/gnome-themes-standard")
+ (synopsis "Manage encryption keys and passwords in the GNOME keyring")
+ (description
+ "Seahorse is a GNOME application for managing encryption keys and
+passwords in the GNOME keyring.")
+ (license license:gpl2+)))
+
(define-public vala
(package
(name "vala")