summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-11-27 22:11:48 -0500
committerKei Kebreau <kkebreau@posteo.net>2018-11-27 22:11:48 -0500
commitc93b77ad37eec647be922377fed2ccb47969938f (patch)
tree71097a32141e98cfd491f7a7947d4d75aa09b4c7 /gnu
parent41ffc214e4839aa50e9957388749772e91a3f533 (diff)
downloadgnu-guix-c93b77ad37eec647be922377fed2ccb47969938f.tar
gnu-guix-c93b77ad37eec647be922377fed2ccb47969938f.tar.gz
gnu: wxmaxima: Update to 18.11.4.
* gnu/packages/maths.scm (wxmaxima): Update to 18.11.4. [source]: Switch to git-fetch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0cf8916abe..b08f6b41ba 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2848,16 +2848,17 @@ point numbers.")
(define-public wxmaxima
(package
(name "wxmaxima")
- (version "18.10.1")
+ (version "18.11.4")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/wxMaxima-developers/" name
- "/archive/Version-" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wxMaxima-developers/wxmaxima.git")
+ (commit (string-append "Version-" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0c2blq65r0am509p3rjqpwqk6vl5r2yg1p9nh2jczf80vhi3ldas"))))
+ "1sz8n9v23q442l7yjj67pjh0dk78rl4cbcc3j8m1bm88anlfxl9r"))))
(build-system cmake-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)))