summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-25 05:16:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-25 05:17:42 +0200
commitbd531e83d1c4320ed8ce031c9b7d3261268fd793 (patch)
tree803ee85c086cc59c4f55b280c9db7b9708c32495 /gnu
parent63fcb88a502054b38cca0e7c4db83529800282f7 (diff)
downloadgnu-guix-bd531e83d1c4320ed8ce031c9b7d3261268fd793.tar
gnu-guix-bd531e83d1c4320ed8ce031c9b7d3261268fd793.tar.gz
gnu: Add r-coin.
* gnu/packages/cran.scm (r-coin): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 1510d0edb3..69ba63d082 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6398,3 +6398,28 @@ comparisons of slopes.")
"This package provides power analysis functions along the lines of
Cohen (1988).")
(license license:gpl3+)))
+
+(define-public r-coin
+ (package
+ (name "r-coin")
+ (version "1.2-2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "coin" version))
+ (sha256
+ (base32
+ "1fq58793bymzig1syjg2lvn6hsxfwkhh00jfrchh3c0y7rfhc66m"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-modeltools" ,r-modeltools)
+ ("r-multcomp" ,r-multcomp)
+ ("r-mvtnorm" ,r-mvtnorm)
+ ("r-survival" ,r-survival)))
+ (home-page "http://coin.r-forge.r-project.org")
+ (synopsis "Conditional inference procedures in a permutation test framework")
+ (description
+ "This package provides conditional inference procedures for the general
+independence problem including two-sample, K-sample (non-parametric ANOVA),
+correlation, censored, ordered and multivariate problems.")
+ (license license:gpl2)))